New installation - Failed to fetch URL's from Source

I have been troubleshooting this for a second since it is my first installation of Storj. I went through all of the onboarding steps and am stuck on this one:

because new user: 2022-03-30T15:21:50.787-0700 ERROR trust Failed to fetch URLs from source {"sour -

I thought I was failing to open the proper port on my firewall, but looking at another issue here, I am not getting the same error, but I don’t know what the error above is trying to tell me. I have reinstalled the program multiple times and attempted to start the service manually as well. Sometimes the installer will pause and fail out and other times it will finish and attempt to open the dashboard. All times I get the same error above.

Hello @Xander ,
Welcome to the forum!

This is mean the broken network configuration. The storagenode cannot load a few kb plain json.
It could be your firewall or router.
You can easily check it - please try to use a mobile internet. If it would be able to download - then you need to check and fix your firewall and router.
There is also a rare case of broken network stack on Windows, specifically - in the Docker desktop + wsl2.
The fix was to remove the Hyper-V virtual switch for wsl2 and reinstall wsl2 (sometimes the reboot is enough even without reinstall of wsl2).

1 Like

I followed the setup directions from the storj site. Was I supposed to add docker/wsl/and hyper-v as well or is this an alternative setup? Also killed firewall on local device and Router and still have the same issue. I can browse to these URLS and view the data.

If you selected a docker version, it’s required to install the docker desktop either with Hyper-V or with wsl2.

Do you have docker? Or is it a Windows GUI installer version?
Do you use any antivirus suite?