New logo and tardigrade gone?

Hey guys, just wondered is there was an update on the new logo and tardigrade website disappearing?

:wink: please stay tuned

Just a quick tip for the future. You might want to inform customers before the fact if the entire name of the product changes. :wink:

I received an email today that was all about the previously unknown Storj DCS. With no mention of the name Tardigrade going away at all. I think support may get some questions from confused customers.

With that out of the way, I’m hopeful to see what comes of this move.

Quick note though, seems the forum logo is broken.

1 Like

Awwww… Poor little Tardi. I liked this smiling face! :cry:


You can still watch the video: homepage | Tardigrade

1 Like

@BrightSilence for the broken logo youre observing, what browser are you on, and can you please send me a screenshot? thank you!

its working for me btw, might just need to clear the cache?

I really dig the new logo design :smiling_face_with_three_hearts:

However, for me the logo on the forum is broken as well (Firefox 88.0 64-bit, I tried Ctrl-F5 already).

@twl can you send me a screenshot? what platform/broswer are you on?

I just did CTRL+F5 and the logo was gone:

The link to the logo is: and produces:

This XML file does not appear to have any style information associated with it. The document tree is shown below.

As said, I am on running Firefox 88.0 64-bit on Win 10 Pro

Did you try clearing cache ?

I’m seeing this in my current browser and in an incognito window. I’m not sure what problem people are seeing.


Hmm. Not sure what’s up with that. That URL is working for me.

Have you performed CTRL + F5?

1 Like

That should clear the cache for the current domain, right?

Btw I’m on another machine now, Chrome Version 90.0.4430.7 64-bit on Win 10 Pro - slighty more broken visuals and Ctrl-F5 again did not help

1 Like

Can you send a screen shot and/or see what assets aren’t loading in the developer console network tab?

Never really used the dev console (I’m not a developer ;). I opened it, cleared it and clicked the broken logo to reload the forum landing page.

Am I in the correct tab for you to see anything interesting?

I’m using Brave (Windows 10), but I first saw it in Chrome on my android phone. Clearing cache doesn’t help. It also doesn’t show up in an incognito window.


It might be an issue with the CDN you use. Tried to access the url directly and…

were looking at moving it, thanks!


That image URL is working for me. I suppose it’s possible that the CDN is broken and it’s working in some zones and not others. That’s my current best guess. Or the browser cached the missing image and won’t reload it.