New node listening on IPv6 only, how to change?

How do I tell the storagenode container to listen only on ipv4? I’m running on a linux server where I cannot disable ipv6 entirely. The firewall ports are only open for incoming ipv4.

I tried putting this into my config.yaml:
# public address to listen on
server.address: “”

but alas the startup log always records:

2019-07-19T22:24:48.677Z        INFO    Public server started on [::]:28967
2019-07-19T22:24:48.677Z        INFO    Private server started on

and after startup I get no communication to other nodes/satellites.

I have another node (working just fine) running with ipv6 completely disabled on the OS and upon startup it reports:

2019-07-17T19:35:37.824Z        INFO    Public server started on

Any ideas?

There is nothing to change. Make sure that your ADDRESS option in the docker run set to the external address with port, for example -e ADDREES=external.address:28967 and make sure that you forwarded the TCP 28967 port to your PC with docker.
The environment variables have a precedence above parameters in the config.yaml.

If your Last contact on the dashboard is lesser than a few seconds - your node is online.

Thanks Alexey, you are right (of course).

When I started this thread I was not seeing an open port for 28967/ipv4 on my host, but now I am and dashboard is seeing contact.

Thanks for your help, especially on the weekend!

1 Like