New Node - not able to get online

Just setup my new on an Ubuntu 16.04 server. All seemed to go well. Once I run the docker image I get the CLI dashboard with the offline status and it has stayed that way for sometime.

I have opened up tcp port 26987 on ufw. Problem is my IP address is shared and I only have tcp ports 50442 to 50449 available other than one each for SSH and RDP.

I installed noip as per the guide and added the hostname it generated to my run command but still no good, obviously tcp 26987 still not open on my vps.

I’ve just started to look at and openvpn. I am really confused now about ports, ip address for my vps, the docker image, the tunnel and my run command?

Can anyone help :slight_smile:??

You need to find out if the ports you have opened are even useable, If your IP is shared its probably not going to be possible to run a node less you ran A VPN, Or obviously Open the ports that you know you have to you. When you say you only have SSH ports 50442 and 50449 for RDP is this a rented server from a data center?

Its a rented VPS yes, however the port range of 50442 to 50449 are available to be allocated, redirected etc by me. SSH is pre-allocated to port 50440 and RDP to 50441, so can’t be changed.
So again, shared IP of 88… has 50442 to 50449 available.

Ok so in your config you can use a port you know that you have and use -p 50442:28967 when you start your docker command. In your ubuntu firewall you would enable 50442 not 28967.

1 Like

Thank you so much - I think this where I haven’t been able to join the dots. has given me a hostname with port 37573 => 26987 mapping. Does that seem right?

No you need it to goto the open port you have which would be 50442. I guess if you use openvpn you would be able to do it that way, But if you are able to have a port thats opened you dont need to use openvpn.

Ok, well simpler is better. The number of steps involved has been part of my self-created confusion :slight_smile:Changed to 50442. Also killed openvpn for time being. Can run later if need be. One question before I go ahead - further in the docker run command there is an address field that I currently have as "portmap.hostname:50442 - should that also change now to "88.....:50442" ?

yes change it to your public IP and port and make sure to change -p 50442:28967

Brilliant! First time ever online with Storj - I thank you Sir :slight_smile:

You are very welcome glad I could help you out. Have a good night.

1 Like

Problem solved in less than 2 hours after the first post? impressive :+1:

1 Like