New Node not using any disk space

Version 0.20.1
Dashboard shows Last contact few seconds ago.
Used, Egress, Ingress - all show 0 B
Neighborhood size is: 157
Been up for several weeks, and only reboots for OS updates.

Logs show loads of ERROR server gRPC unary error response {“error”: "rpc error: code = PermissionDenied desc = untrusted peer

Logs also show ERROR nodestats:cache Get stats query failed {“error”: "node stats service error: unable to connect to the satellite xxxxxx: transport error: context deadline exceeded;

Please advise on what is going on here, is there something wrong?

Hello @bkdilse,
Welcome to the forum!
Please, post the output of the commands:

docker exec -it storagenode grep -c BEGIN /app/identity/ca.cert
docker exec -it storagenode grep -c BEGIN /app/identity/identity.cert

Then this one:

for sat in `docker exec -i storagenode wget -qO - localhost:14002/api/dashboard | jq .data.satellites[] -r`; do docker exec -i storagenode wget -qO - localhost:14002/api/satellite/$sat | jq,.data.audit; done

for sat in docker exec -i storagenode wget -qO - localhost:14002/api/dashboard | jq .data.satellites[] -r; do docker exec -i storagenode wget -qO - localhost:14002/api/satellite/$sat | jq,.data.audit; done

Is there any command on windows host for this?

Hello @VinC,
Welcome to the forum!
You can use the script from our fellow member @Krey:

wget: server returned error: HTTP/1.1 500 Internal Server Error

Any ideas what is wrong here ?

Do you have a string


in your config.yaml? if so, please, comment out it and restart the container: docker restart -t 300 storagenode
Then try to get a stat from your integrated API

Also, make sure that your docker image is updated to the beta tag

Similar issue for me - egress traffic is zero from the node activatio, also whenever I restart the container the Used count restart. The output of the command above:

"12EayRS2V1kEsWESU9QMRseFhdxYxKicsiFmxrsLZHeLUtdps3S" { "totalCount": 0, "successCount": 0, "alpha": 1, "beta": 0, "score": 1 } "118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW" { "totalCount": 0, "successCount": 0, "alpha": 1, "beta": 0, "score": 1 } "121RTSDpyNZVcEU84Ticf2L1ntiuUimbWgfATz21tuvgk3vzoA6" { "totalCount": 0, "successCount": 0, "alpha": 1, "beta": 0, "score": 1 } "12L9ZFwhzVpuEKMUNUqkaTLGzwY9G24tbiigLiXpmZWKwmcNDDs" { "totalCount": 0, "successCount": 0, "alpha": 1, "beta": 0, "score": 1 }

I use the latest beta image. This is the image digest:

Here is also the tail of the the log:

Any suggestion? thx

Sorry for late reply, I did not get a notification on this response.
I’ve just removed and updated to the latest version (beta).

I do not have the console.address enabled (so it’s already commented out).

Now i’m getting a different error:

jq: error (at <stdin:1): Cannot iterate over null (null)

The following returns node information:

docker exec -i storagenode wget -qO - localhost:14002/api/dashboard

@Alexey Kind of got further now. My Node runs being a firewall/proxy. I re-configured node to bypass firewall/proxy, and I can see satellites in the above command. Question now is how to I run this behind the firewall/proxy?

I do not have UPNP enabled. Do I need to simply open a range of ports?

I would not recommend exposing the ports to the public internet if that’s what you’re asking. Better to set up a vpn and connect to the network using the vpn.
If it’s a local firewall, yes, just open the ports.

When I say open ports, I mean outbound. I only have the 1 required port open.

Outbound all ports need to be open.

Thanks, that must have been the problem all along. Dam, I waste uptime. Oh well. I’ll leave it on now, and see how it goes.

You can use a ssh tunnel

ssh -nNT -L 14002:localhost:14002 your.public.address

Then open in your browser http://localhost:14002

Of course the 14002 need to be mapped into the container in the docker run command like -p

1 Like

Would that not require ssh to be remotely accessible? I would not recommend that unless you enforce public key authentication.

I use only public keys authorization.
Also, I uses a different port from a standard and configured the ~/.ssh/config to hide all complexity with a different ports, users and gateways (yes, I have a bastion host too and fail2ban enabled).

1 Like

That’ll do it, but unless you really know what you’re doing to protect it, I would recommend using OpenVPN over public SSH access of any kind. Less chance to screw that up and open the door to everyone. It also saves you from having to open specific ports since you are just on the same network that way.