New Node Offline (misconfigured)

I need some help with my misconfigured node, I’m not sure what’s wrong but all ports have been forwarded correctly to the correct IP. I have even tested to see if the port is open and it is. I’ve recently setup another device that needs ports to be open on the helium network and that worked perfectly so I know my ISP allows ports to be opened. I have the correct ERC20 wallet address and correct email address but for some reason the node is still showing offline.

Did you allow in windows firewall?

1 Like

Neither wallet nor email will make the port forwarding working, you need to actually forward the port on you router.
You also need to allow inbound connections to the port of the node for both protocols - TCP and UDP. If it’s a first node, I suppose you use a default port 28967, so it need be forwarded on your router and allowed in your firewall.
You also need to use this port in the configuration of your node - it should be part of the external address, -e ADDRESS=your.ddns.address:28967 if you use a docker or contact.external-address: your.ddns.address:28967 in the config.yaml, if you use a binary.

Yea I done in both router settings and windows settings

I have done all of this but it’s still not working, my config file reads,

the public address of the node, useful for nodes behind NAT


I have have the exact same on the outbound settings too.

You must use the external IP, not the local. If this IP is your WAN IP - then you do not have a public IP.
In such case you have several options:

  • call to your ISP and ask for the public IP, it can be dynamic, but must be a public (the WAN IP will match IP on Open Port Check Tool - Test Port Forwarding on Your Router); you can say that you need an access to your security IP cam to do not explain Storj to ISP’s staff;
  • switch to ISP who offer a public IP;
  • use VPN services with port forwarding feature, such as, PIA, AirVPN, PureVPN, etc.

Yea I have just switched this to my external IP which I got from the port checker tool. It’s still not online

Make sure that your WAN IP is match the IP on yougetsignal. Otherwise your port forwarding will not work.
If you changed the config.yaml, you need to save it (menu File - Save), then restart your storagenode service either from the Services applet or from the elevated (as Admin) PowerShell:

Restart-Service storagenode

Perfect, I’m online… it needed a restart!

1 Like

I need help, my newly created node has an offline status and miss configured status, I have input the correct IP and setup the correct port forwarding. I’m lost if anyone can help?

Seems duplicate. And now this problem is fixed, am I right?

Please do not create duplicate posts for the same problem, thanks.