New storage node setup, wallet address question and service not starting issues (windows gui)

Hello, I’m new here, this is my first post. I’m pretty new to crypto but STORJ looked appealing to me for a small investment so I bought some yesterday and wanted to also increase my earnings by participating as a storage node.

I’m having a technical issue with the service that I will get to in a minute but I had a question regarding wallet address and payouts first.

When installing the node, it asked me for my payout wallet address. I have coinbase but I read thats not optimal for this (if working at all). I ended up installing and setting up a “Trust Wallet” and in my trust wallet I have an ETH wallet and I also have a STORJ wallet.

Do I provide my ETH wallet address or my STORJ wallet address for payouts? I’m really not clear on this… I do plan on activating zkSync once I get up and running if that makes any difference on which wallet I use please explain if you can…

Now my technical issue. I have about 500GB to spare right now and I think that was the minimum so when I installed I created a folder for the data and pointed the installer and entered 0.5 TB as the size of the node.

It goes through the installer and what not but when its done the dashboard wont open and I just get a connection refused message in my browser. Upon further inspection, the actual service is not running and when I try to start it it just stops immediately and throws error 1067 that the process terminated unexpectedly.

My chkdisk comes back clean on the drive and the drive works fine as I have plenty of other media and things stored there.

Also, the storage node data folder has the following items:

Folders (all empty):

  • blobs
  • garbage
  • temp
  • trash

A single file called: storage-dir-verification (1KB) which if you open in a text editor just has what appears to be 32 bytes of binary data (far under the 1KB windows reports lol).

I do not see any “database” files that I have seen on other threads where users were having the same 1067 service error.

I have tried to reinstall and that did not fix anything. Not really sure what to do here.

Your Storj address. Storj is an ERC-20 token on the ETH network that uses its own addresses.

The minimum is 500GB space with around 10% overhead, so a 500GB hard drive won’t work out of the box. You can however decrease the assigned space after installation.

This is however most likely not related to the error you get. Did you follow the FAQ exactly for your installation?

You can re-download the .msi and try installing again :slight_smile:

twl: Thanks for the swift reply!

I was just going through another thread where someone had a similar issue and first I tried changing the log level to debug and then started it, and checked the log after it failed and nothing new “debug” wise was added. I then found another command line trick to run the node and put the debug level output to the STDOUT and that did give me the information I needed to fix the issue. I had a type-o in my free “no-ip” host name for my public address so the DNS lookup was failing and it was exiting.

They should definitely have better error reporting when things dont work. It was a pretty obtuse way of finding out that I just had a typing error in one of the configuration values… either way I’m happy that its working now.

The drive I’m using is 6TB but I wanted to dedicate 500GB for now until I can get another drive. Is the .5 TB setting going to work ok for this?

Also, now that my node service is running and I can see the dashboard, I can see that I’m still listed as “Offline” but my uptime is 6 minutes, but my last contact is 17709306H and 14M ago… Does this just take a while before it turns on or do I still have something else configured wrong?

Scratch the offline question, figured out that it was a port / firewall configuration issue. Online now! woohoo!

3 Likes