New user, storagenode is stopped, dashboard is "This site can’t be reached"

I installed everything needed, used a youtube tutorial “How to Setup A Storj node WINDOWS 10 (V3) (easy – profitable in 2020) RENT OUT HARD DRIVE SPACE”.

Not sure what I have done wrong, if I have done port forwarding wrong or anything else, when using powershell, it says Storj is not running, when I try to get it running, nothing appears. Now when I try to start it, it says "start-service : Service ‘Storj V3 Storage Node (storagenode)’ cannot be started due to the following error: Cannot
open storagenode service on computer ‘.’.
At line:1 char:1

  • start-service storagenode
  •   + CategoryInfo          : OpenError: (System.ServiceProcess.ServiceController:ServiceController) [Start-Service],
      + FullyQualifiedErrorId : CouldNotStartService,Microsoft.PowerShell.Commands.StartServiceCommand" in red.

Port forwarding screenshot:

Not only that, the dashboard that opens, the localhost 14002, it says site cannot be reached on chrome, also does not work on Edge. What have I done wrong? I didnt use docker, used the windows GUI install.

Im assuming you did all the steps before installing windows GUI

Did you try to run powershell in Admin and try starting your storage node that way?

Check your processes and make sure storj-gui is even running before trying to check the dashboard.

You can check your logs with this command: Get-Content "$env:ProgramFiles/Storj/Storage Node/storagenode.log" -Tail 20 -Wait

Apparently I cant post 2 or more links, here it is:

2020-02-19T11:44:39.915Z ERROR Invalid configuration: invalid contact.external-address: lookup “http” failed: lookup http: no such host

Configuration loaded from: C:\Program Files\Storj\Storage Node\config.yaml

contact.external-address: what’s in there?

Here you have the official Storj documentation:

Make sure to use your public IP address in the contact external address.

In there its contact.external-address:, thats my domain I got from no ip website from the tutorial.

So inside of the notepad, instead of having external-address of by No IP, i should have my IPv4 eg 123.456?

Yeah I would not use that address you need to put if that is your noip address.

Yeah I do have that as the address but the dashboard still does not load and powershell says Status Name DisplayName

Stopped storagenode Storj V3 Storage Node

So I guess nothing is working, not sure why

When you check your process does it say storj-gui running?

Not sure how to check the GUI process but Storj V3 Storage Node is not running on Powershell

Also in the log, the same error pops up: Invalid configuration: invalid contact.external-address: lookup “http” failed: lookup http: no such host

In task manager you should see it, in processes.

This is because you need to restart the process cause its probably still running after you edit the file.

Remove http:// and / from your no-ip address.

It should look exactly like


The only thing I found was storagenode-updater program (Storj V3 Storage Node Updater). Also the address was the same no ip address so I didnt change anything, just closed the notepad.

I know but if http and the / is there it will not work.

You need to remove http:// / and look like this

Done that and closed the notepad and it saved. Restarted the laptop but Storj V3 still isnt running and dashboard cant be reached.

Done that change and restarted my laptop, its still not running and dashboard doesnt load on chrome, says site cannot be reached

Check your logs now what does it say?

It hasn’t changed since few hours. No changes, same error Invalid configuration: invalid contact.external-address: lookup “http” failed: lookup http: no such host

Powershell says Stopped - Storj V3 Storage Node