Nextcloud on Storj?

Sorry, I misspoke myself.
Of course, if I use tardigrade as an external backup, I wouldn’t do it directly through Nextcloud. I would rather use another backup solution to create an archive or something like that and then send it to tardigrade.

@keleffew @kevink Is this information still true?

It was few weeks ago when I tried again

Is there any news about cooperation?

Time goes by, I am looking for information and I do not see anything.

Hi @vovannovig! Check out this latest update as of a week ago :slight_smile:

https://apps.nextcloud.com/apps/storj

5 Likes

That’s great! Out of curiosity, how is this app making the use of the S3 gateway unnecessary?

Yes, I tested it and it works. With this app you do not need an s3-compatible gateway anymore.
Just follow instructions on GitHub.
After installation it will appear as a connection method in External storage.

1 Like

I just tested the nextcloud storj app and encountered the following issue: while I am able to access my bucket, when downloading a file, it only downloads the first 64M of it. I also tried to upload a file (~120M) and only a 64M segment of it is effectively uploaded.
Anything I may have done wrong?
Thank you!

Unfortunately, I’ve had the same issue 1 year and a half ago :confused:
I don’t know if someone knows what’s happening and how to fix it. I thought it would be already fixed.

I did not experience any issue when combining Nextcloud with Storj S3 gateway (contrary to your experience 1 year and a half ago). Here, I’m only talking about the new standalone app for Nextcloud (which is definitely a very good improvement in terms of onboarding experience, if only it worked well :slightly_smiling_face:)

Any news on an upcoming update of this app? @Erikvv? Thanks!

I’ve just released a new version (v0.0.5) with the fix for this issue. It usually takes a day for the app store to display it.

1 Like

Thanks @Erikvv! I’ll give it a try and provide my feedback ASAP.

Just bumped into this error:

The bucket name is correct as well as the access grant. Any idea what it could be about?

Thanks!

Created issue. I am befuddled as to why I don’t have this error.

What satellite are you on?

eu1 it is (and a couple more words for 20 chars)

Just to be sure, have you restarted fpm/apache after update?

(else it might have cached remnants of the old .so lib file)

Just restarted both services and the same error pops up :slightly_frowning_face:

We’ve made a fix of the suspected issue, that will be in the next deploy to the satellite.

@silaxe

3 Likes