No Ingress on one of my nodes since 5/12

I’ve noticed that one of my two nodes stopped getting any ingress since 5/12 (which might correlate when I got 1.29.3 but not sure). There is periods when ingress returns but than quickly goes away. I still have space available and I’m running version 1.29.3 which I’ve verified is the latest version. I have a second node (in a completely different location) which is running the same version and has not run into this same issue. I am still getting Egress and the node is still stating online with a perfect audit score. I had not changed anything on this node so was surprised to see the ingress drop off so dramatically.

Looking at the logs the only errors I see could be related as it seems like it fails to get storage stats from the nodestats. But not certain why this would have started all of a sudden.

2021-05-16T14:08:57.810Z        ERROR   nodestats:cache Get disk space usage query failed       {"error": "node stats service error: context canceled", "errorVerbose": "node stats service error: context canceled\n\*Service).GetDailyStorageUsage:114\n\*Cache).CacheSpaceUsage.func1:177\n\*Cache).satelliteLoop:261\n\*Cache).CacheSpaceUsage:176\n\*Cache).Run.func3:132\n\*Cycle).Run:92\n\*Cycle).Start.func1:71\n\*Group).Go.func1:57"}
2021-05-16T14:09:28.206Z        ERROR   nodestats:cache Get stats query failed  {"error": "node stats service error: context canceled", "errorVerbose": "node stats service error: context canceled\n\*Service).GetReputationStats:74\n\*Cache).CacheReputationStats.func1:154\n\*Cache).satelliteLoop:261\n\*Cache).CacheReputationStats:153\n\*Cache).Run.func2:120\n\*Cycle).Run:92\n\*Cycle).Start.func1:71\n\*Group).Go.func1:57"}

Hi @Sokar and welcome to the forum! :slight_smile:

That’s a bit concerning, maybe something’s up with your disk.

You should probably run a fullscan to ensure it’s fine and is not starting to fail.

If you’re on linux, maybe this thread can give you some hints on what to do to check the disk if needed:

I get also no ingress data since a while.
checked log and but haven’t seen something suspicious: The “uploaded” entries just disappear.
Download and delete entries remain until now.
Status and QUIC are green, but online percentage goes down.
I am running v1.47.3 with autoupdate.
Tried good old restart of both: software and hardware, but with no effect.
DynDNS looks good


1 Like

Thanks for the quick answer.
I am now struggeling with the config file:

I was using docker on a raspberry pi.
I have to switch to the binary version or wait, do I get this right?
I am trying to use the binary, but it refuses to load the operator.* variables of the config, although I set the values: operator.wallet: "0x19d106b9f7e7836d4848fab0146131a6e4a88a2a"
I get the following feedback, if I try to run ./storagenode run :
2022-03-30T21:05:25.390+0100 INFO Configuration loaded {“Location”: “/home/pi/.local/share/storj/storagenode/config.yaml”}
2022-03-30T21:05:25.397+0100 WARN Operator email address isn’t specified.
2022-03-30T21:05:25.397+0100 ERROR Invalid configuration. {“error”: “operator wallet address isn’t specified”}
Error: operator wallet address isn’t specified

If you use docker, you should specify all parameters in docker run command, not in config.yaml.
See Storage Node | Storj Docs

Please update your node manually: Software Updates | Storj Docs, then configure automatic updates.

If you run a 32 bit OS, then you should wait for the next version, it should be with arm32 support.
But now please update to at least 1.49.5: 6e7a89161-v1.49.5-go1.17.5

Thanks for all your help: My node is online again!

What happend:

  1. I was running docker on arm32 and was excluded because of an old version.
  2. Autoupdate was not reacting and manual update from the instructions was not working because of non matching architecture.
  3. So I tried to run a newer version from binary without docker and edited the config.yaml. From this point my node was not even reachable anymore.

I solved it through switching to 64bit architecture, deleting the config.yaml and setting up the docker node again. Took me quite some time to identify the problem but I am happy again. Nice software!

1 Like