Node connection problems after a power outage

hi guys today due to bad weather the current suddenly stopped …
i tried to restart the node but i have problems, what can i do?

I would recommend turning off write cache on the drive which your running your node on.
Heres a site where you can fix this issue you will need to follow it.,databases%20may%20have%20become%20corrupted.

I tried to run the guide but I can’t get the node to work, I probably made a mistake in some step, is there another way to reset the node or fix the errors?
and I run a 16.03tb node on Windows 10

  1. You should not run the storagenode binary from the PowerShell, unless you decided to avoid using of the standard installer.
  2. Close your terminal, where you started it manually and start the service instead either from the Services applet or from the elevated PowerShell:
Start-Service storagenode

It should start the service with correct configuration from the C:\Program Files\Storj\Storage Node\config.yaml (not the default location, when you run it manually).
Then check your logs:

Get-Content "$env:ProgramFiles/Storj/Storage Node/storagenode.log" -Tail 20 -Wait

P.S. When you start storagenode.exe from the PowerShell, you must provide at least a --config-dir "C:\Program Files\Storj\Storage Node\\" option, otherwise it will create almost empty config in the "%AppData%\Storj\Storagenode". This config will point to the default data location, i.e. "%AppData%\Storj\Storagenode\storage". And of course there would be no databases or data.
Your data probably located on some other disk, not the system one. So please, do not run just storagenode.exe without options.

thank you for answering me …
i started the node from or from powershell with elevated privileges
and these are my logs

You need either to fix the bandwidth.db (it’s in the data location folder) with or re-create it with if you do not care about bandwidth usage history on your dashboard.

I followed this guide

and the knot comes alive … just for a few minutes

I checked for disk errors with automatic fix and now the node is working
thanks for your help as very kind smpre :sweat_smile:

1 Like