Node Dashboard Never Finishes Loading

I’m running storj on docker on ubuntu. The web dashboard used to load fine. I updated it about a week ago and now the dashboard won’t load. It just spins but the data doesn’t load. If I check the docker logs, it looks like there is activity going on.

Sometimes I come back to my computer in the morning the page has loaded but the data is inaccurate or blank. Where can I check to see what’s going on?

Welcome to the forum @kerwinc!

Can you check if you are using the correct URL ? You can post it here.

Thanks for the welcome. Yes, the URL is correct since I get the loading image but it never loads. The image just keeps spinning.

Try using CTRL + F5 on the page.

Ctrl + f5 didn’t work. I’ve also tried different browsers with the same result. Just now, I removed the docker image and pulled the latest again and now it’s working. I’ve done this about 5-10 times within the last week to try to get it to work, not sure why it’s working now since I don’t think the version has changed. Not sure how long it will last but I will post if it happens again.

I have seen this where the dashboard takes longer to load than normal, although never more than 30s extra on my system. This usually happens when the disk is being thrashed for one reason or another. Do you happen to know if your disk is an SMR disk? When the behaviour is occurring, check your I/O wait times. Perhaps your disk is having a difficult time keeping up. You can use this command:

iostat -p /dev/sda -y 5

-p /dev/sda shows only the specific disk. Omit to see all disks, or change sda to your storage drive
-y 5 refreshes the output every 5s

You should be mainly concerned with the %iowait value at the top of the output.

I too am getting this. Activity is going in the logs. Restarting the docker image fixes it for about 6 hours then quits again.

Welcome to the forum @lordjynx!

Can you show your docker run command? You can remove any personal information from it like wallet, email address.

I used docker-compose but reverse engineered it for you using rekcod:

docker run --name storj --runtime runc -v storj_config:/app/config:rw -v storj_identity:/app/identity:rw -p 14002:14002/tcp -p 28967:28967/tcp --net skynet --restart unless-stopped -h 3a62302ead4f --expose 14002/tcp --expose 28967/tcp -l com.docker.compose.config-hash=‘xxx’ -l com.docker.compose.container-number=‘1’ -l com.docker.compose.oneoff=‘False’ -l com.docker.compose.project=‘username’ -l com.docker.compose.project.config_files=’/home/username/docker-compose.yml’ -l com.docker.compose.project.working_dir=’/home/username’ -l com.docker.compose.service=‘storj’ -l com.docker.compose.version=‘1.25.0’ -e ‘PUID=1000’ -e ‘PGID=1000’ -e ‘TZ=America/Chicago’ -e ‘WALLET=0x00’ -e ‘EMAIL=user@emailaddress’ -e ‘ADDRESS=xxx:28967’ -e ‘STORAGE=4TB’ -e ‘PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin’ -e ‘GOARCH=’ -d --entrypoint “/entrypoint” storjlabs/storagenode:latest

I should mention that the dashboard.sh does this as well (never shows the “dashboard”)

@nerdatwork any ideas/insights?

It appears to still be functioning except having to restart the docker to get the dashboard back.

The only known solution - do not keep it running. Run it when you actually want to check it and close it, if you do not need it

@alexey Not sure I follow. I don’t leave the dashboard running 24/7. I check it occasionally and have to restart the docker image to get it to load.

I am not familiar with docker-compose but are you able to access web dashboard.

Then it’s more interesting issue.
Could you please, setup a debug


and give me results of the curl localhost:5999/mon/funcs (if you would post it here, put before the first line the line with a three backticks ``` and the same line with three backticks after the last line) when you trying to run a CLI dashboard.

And could you check - is the web dashboard working?

When the docker startt fails to launch the dashboard, then something goes so horribly wrong that it crashes the whole docker image and I am unable to stop the docker image after that point.
The only way is to reload the whole docker service:

sudo systemctl daemon-reload
sudo systemctl restart docker

What is your OS?
What is a docker version?

Raspbian GNU/Linux 10 (buster) 5.4.51-v7l+
Docker 19.03.13

Could you please check the RAM usage when it happen again?
Please, show the result of the command:

docker ps -a

not while it’s doing this, no.