Node doesn't go online lookup failed

Hello,
I created a new storagenode running with docker on CentOS 8. The node isn’t working because there is some type of lookup fail.

Error: invalid contact.external-address: lookup “mydomain.de” failed: lookup mydomain.de on 192.168.0.1:53: read udp 172.17.0.3:37498->192.168.0.1:53: read: no route to host

I opened the port 28967 on both my router and firewall-cmd. What can I do about it ? A lookup shows my external IPv4 as it should. Thanks!

Are you sure you are using your ddns:28967 in your docker run command under -e ADDRESS?

Yes I’m using that. I tried 2 different domain names. All resolve to my external IPv4.

Did you happen to put your local IP address where your public IP address should be when entering it into the DDNS?

No, and my router is updating when IP change occurs. I’m using https://freedns.afraid.org/ with my own domains.

Try running a whois on your domain and see what it comes up as.

Only shows my DNS Records. I setup www.domain.de and domain.de as A type pointing to my external IP. Though I don’t need the www one.

This is CentOS specific problem with docker
You can take a look on this:


And other similar issues specifically with CentOS: https://forum.storj.io/tag/centos

Thank you! These commands solved my problem :slight_smile:

$ sudo firewall-cmd --zone=public --add-masquerade --permanent
$ sudo firewall-cmd --reload
$ sudo systemctl restart docker
1 Like