"Node is Below the Minimum Version" while GE

Today I got emails saying my node is running below minimum version on the satellites. I’m currently running 1.74.1 and doing GE from all satellites. Using 1.74.1 because 1.75.2 was causing frequent crashes and I didn’t want to risk a clean GE.
Since I’m already doing GE do I need to update (causing - almost sure - GE to fail) or can I keep using 1.74.1 untill GE finishes?

I have the same issue, hopefully finishes ok

Have 1.74.1, got email saying it’s below minimum ver.
Newest version i saw on my other node was 1.76.2
So i tried to auto update, restarted services under windows, still 1.74.1
Then i downloaded manually the newest version from www docs.storj
Still it downloads 1.74.1. (its marked latest on storj’s github)
Can someone upload newest version to docs.storj to download please? or fix that email, thx
Downloaded manually 1.76.2 from github and instaled it.
Its for GUI Windows.

Running below minimum version is fine, you just won’t get new data but doing GE this doesn’t matter and it should finish without issue.

The alternative would be to specify both intervals and timeouts for checkers to the big value like a month or two (this is how it works in versions before 1.75.2).

Your would need to restart an storagenode-updater service likely, because it seems stopped.

I restarted it, and i restarted whole computer im telling You, it downloads whats marked latest and latest was 1.74.1. Also this was true when i went to docs.storj to download it manually. So i discovered docs.storj download GUI Windows is linked to github, so i went to github directly and i downloaded 1.76. ver (its marked pre relase, but if Your email i bothering me 1.74 is not enough? so i installed manually that pre released version, hope You satisfied).

EDIT: now storagenode-updater downloads 1.76.2 version, so its fixed i would say.