Node is online after restarting computer, then goes offline for awhile with this error...any tips?

Hi I am trying to set up a node but am having some issues with it staying online. It starts as “offline” unless I restart the PC, in which case it will connect for awhile before getting disconnected and changing back to “offline” status with a “connection refused” error in the logs.

I’ve confirmed that the port forwarding is set up and active so I am not sure what could be causing this. Any insight?

You should start by making sure your no-ip is working and updated. Open Port Check Tool - Test Port Forwarding on Your Router
Also make sure you confirmed your no-ip since every 30 days you need to reconfirm it.

Yes looks like the port to the storagenode is not open:


The connect/disconnect issue you describe suggests some kind of firewall is allowing traffic and then blocking it due to some rule.

Ping request could not find host Please check the name and try again.
please check you ddns is up to date, you need to setup router with it, or install ip update software

It’s which resolves.

check windows firewall it is opend?
also that storagenode is added to allowed for comunication list to firewall

They didnt mention which OS its running on. So not alot of info to go on.

Apologies for the late reply. It is on Windows 10. I have confirmed windows firewall matches the troubleshooting guide for offline node, as well as confirmed No-ip is active. Let me know if there is anything else you guys can think of or if some other info would be helpful

it is posible you are behind ISP NAT, so asc your internet provider.

Could you please compare the WAN IP on the status page of your router with IP on Open Port Check Tool - Test Port Forwarding on Your Router , they should match, otherwise port forwarding will not work.

Since you use the NoIP, it’s better to configure it on your router (it’s usually in the DDNS section) rather than on your Windows PC. But please, use only one of these method - either configure the updater on router or DUC on your PC.

The next thing to check - is your identity: Identity - Node Operator

They do not match so it looks like that is the issue. I’ve removed NO-IP program from my PC and have logged into NO-IP through the router instead. Testing now

It looks like the router is updating correctly to match NO-IP but the IP when I go to Open Port Check Tool - Test Port Forwarding on Your Router still does not match the NO-IP address. I uninstalled the DUC software from the PC and restarted but it still is unchanged. Any advice?

In such case the NoIP will not help - your ISP placed you behind their NAT. You have a few options:

  • call to your current ISP and ask for public IP, it could be dynamic, but must be a public (WAN IP will match the IP on yougetsignal). You can say that you need to have an access to your security IP cam from anywhere to do not explain Storj;
  • switch ISP to one who offer a public IP;
  • use VPN services with port forwarding option, such as, ngrok, PIA, AirVPN, PureVPN, etc. Or own server with external IP + OpenVPN/ssh and proper routing.

I think I just needed to restart after uninstalling. I think I had restarted only after changing the router settings. IP now matches on router and port checker tool. Will test and update. Thanks!

1 Like