Node keeps restarting, log has fatal error

Hey!
So I tried setting up a node today but it just keeps restarting
some info

docker run -d --restart unless-stopped -p 28967:28967
-p 127.0.0.1:14002:14002
-e WALLET=“0xdcE8aD7015106f15c70B94B98a76”
-e EMAIL="email@gmail.com"
-e ADDRESS=“192.168.1.76:28967”
-e BANDWIDTH=“324TB”
-e STORAGE=“3.4TB”
–mount type=bind,source="/storj/id",destination=/app/identity
–mount type=bind,source="/media/mitch/Storj HDD 1",destination=/app/config
–name storagenode storjlabs/storagenode:beta

after I run docker logs --tail 20 storagenode

Hi.
It looks like your system is read only.
Try to change owner. Sudo chown -R username /Path/to/folder

Path to folder is your storagenode folder

Restart the node and se whats happens.

1 Like

did you mount your disk by fstab ? it can be because wron disk mounting.

2 Likes

You must mount your disk via /etc/fstab, disk should be formatted and your user have a write rights to that disk.

here is to be the external IP of your router “seen” from the internet

Please, do not use any wordprocessors to form the command, they will replace quotes, dashes to a special symbols, which are not valid for terminal. You can use only plain text editors.
Please, copy the command again from the documentation and replace <whatever> to your values.
The quotes must by straight, not curly, the double dashes should be double dashes, not the long hyphen.

Yeah I think I didn’t do the static mounting portion correctly. I might just restart everything with a clean install of Ubuntu. I use to be on V2 using windows and my two HDD have 134mb ish partitioned to windows, I think it caused my mount to not work because I had

The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Falling back to read-only mount because the NTFS partition is in an
unsafe state. Please resume and shutdown Windows fully (no hibernation
or fast restarting.)

So I’m going to reformat those.

When I static mount does each drive need to be in its own folder inside the mnt folder? I might have messed up there as well.

Also I made sure I had straight quotes and double dashes.

I appreciate the help so far

Yes, they must be mounted each to own folder.

oh so I need my router ip?

You need to do port forwarding: https://documentation.storj.io/dependencies/port-forwarding
To make it working your WAN IP on the status page of the router must be the same as on https://www.yougetsignal.com/tools/open-ports/