Node offline ? 1.4.2 version

This is working, i got 2 and 3, so my identity is correct…
Maybe i’m disqualified ?

Then you would see such message on the web dashboard.
Is your port open on yougetsignal?

Also, please, show the last 10 lines from your log (Powershell):

Get-Content -Tail 10 "C:\Program Files\Storj\Storage Node\storagenode.log"

And status of the storagenode service:

Get-Service storagenode*

Both are running, storagenode and updater
log file is 2,4gb … That’s awsome !
Too much time for open it in notepad, can i delete it ? And give you the 10 line when the logfile will be created ?

You can do it in powershell

Get-content -tail 20 PATH_TO_FILE;

I went with 20, as 10 might not be enough. You can also rename the file and restart the node. It will be recreated and small enough to open. The log could contain useful info, so I don’t recommend removing it and throwing away the kind of info you would need to diagnose the problem.

I got this :

so what should i do ?

Do you see any other messages (the same command)?

Please, stop the storagenode service either from the Services applet, or from the elevated Powershell and rename your current logs, then start the storagenode back

Stop-Service storagenode
mv "C:\Program Files\Storj\Storage Node\storagenode.log" "C:\Program Files\Storj\Storage Node\storagenode-$(get-date -Format 'yyyy-MM-dd').log"
Start-Service storagenode

Wait for at least 5 minutes, then show result of the command (Powershell):

Get-Content -Tail 20 "C:\Program Files\Storj\Storage Node\storagenode.log"

Also, please, put the address from the contact.external-address: option of the "C:\Program Files\Storj\Storage Node\config.yaml" to the Remote Address and port to the Port Number on https://www.yougetsignal.com/tools/open-ports/ and click Check


No more error, but still offline in my node dashboard…

Then I forced to ask you:

  1. to write down your WAN IP from the main page of your router. Then go to the https://www.yougetsignal.com/tools/open-ports/ and compare the IP with written WAN IP.
    If they do not match - the port forwarding will not work.
  2. Please, show your port forwarding rule.
  3. Please, put the address from the contact.external-address: option of the "C:\Program Files\Storj\Storage Node\config.yaml" to the Remote Address and port to the Port Number on https://www.yougetsignal.com/tools/open-ports/ and click Check

Post results.

1- image
2-


3-image
image

Everything seems ok…

Do you have other nodes on that PC?

Make sure that the dnscache service is running.
Try to open your dashboard in the Chrome or Edge and hit the Ctrl-F5.

If it’s still offline, open an elevated Powershell and execute:

New-NetFirewallRule -DisplayName "Storj v3" -Direction Inbound -Protocol TCP -LocalPort 28967 -Action allow

No, i just have 1 node on the pc.
Dnscache is running, i restart it, same issue
Refresh the dashboard lead to nothing.

Same problem with the powershell line.

Do you have any oubound rules in your firewall?
Do you have any firewall on your router?

Please, run the CLI dashboard from the Powershell:

& 'C:\Program Files\Storj\Storage Node\storagenode.exe' dashboard --config-dir 'C:\Program Files\Storj\Storage Node'

Crazy… I’m struggling to reinstall my setup because I thought I broke it. It just went offline randomly on it’s own and wouldn’t come back online. I’m in the process of setting up again.

My node goes offline every night and need to restart my computer every morning just to get it to start up again.

Yeah, the oubound rules is ok.
No firewall on router.

That’s strange because it worked well before…

Hello @donniedice,
Welcome to the forum!

I’m sure, you have a complete different issue. Most like you external address has changed every time. You need to setup a DDNS and use it instead of IP in your config.yaml (or ADDRESS parameter in case of docker): https://documentation.storj.io/dependencies/port-forwarding
Also, make sure that WAN IP on your router is the same as on https://www.yougetsignal.com/tools/open-ports/

In additional, your local IP of your PC can be renewed by your router, if you didn’t make it static.

@Muddy1212 I would like to recommend you the same - make your local IP static either on your router or PC and use the DDNS address as your external address instead of IP. I would recommend to setup the update of the DDNS address on your router, if it’s capable to do so (it’s usually in the DDNS section). If not - then use an application of the chosen DDNS provider. In case of NoIP it’s called DUC.
But use only one of the method to update your DDNS address - either with router or with application.

@donniedice and @Muddy1212
Please, check that your external address is specified in conjunction with the port, i.e. external.address.tld:28967
Also, please, show the last 20 lines from your logs: https://documentation.storj.io/resources/faq/check-logs

1 Like

Can I assume, that you have outbound rules? If so, please, disable them or add a new one to allow any source port and any port and any host as a destination.

Also, it’s possible that your ISP has started to filter your traffic: