Node repeatly stop every hour (My second new installed node)

Hi team,

I am setting up my second Storj node.
But i got the issues that , every hours , the node will be terminated, related : storagenode-updater.

Did anyone has the same issues?
Log screen capture is attached.

I am manually restart it, it will work for a hour and terminated again. Very strange.

I had tried manually update and automatically update. But no luck. : <

Hello @my_kenneth ,
Welcome to the forum!

Please allow it to update. I hope you have --restart unless-stopped option in your docker run command.
What logs shows after the node is terminated inside the container?

Hi @Alexey ,

Thanks for your reply.

the start command that i run (some value masked)

docker run -d --restart unless-stopped --stop-timeout 300 \
    -p 28967:28967/tcp \
    -p 28967:28967/udp \
    -p \
    -e WALLET="0xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxc600F" \
    -e EMAIL="" \
    -e ADDRESS="999.203.249.999:28967" \
    -e STORAGE="4.5TB" \
    --user $(id -u):$(id -g) \
    --mount type=bind,source="/root/.local/share/storj/identity/storagenode",destination=/app/identity \
    --mount type=bind,source="/mnt/storj",destination=/app/config \
    --name storagenode storjlabs/storagenode:latest

The log after termination.

Console looks normal before termination

after 90 mins, it was terminated again.

My manual solution, write a script to check the docker is exit or not. If it is exited, run the restart command.


 while true

	docker ps -a | grep storagenode | grep Exited

	if [ $? -eq 0 ]; then
	  echo "Terminated!!!"
          docker restart -t 300 storagenode
	  echo "Storj is still running!"

 sleep 30

hi @Alexey , what do you think? :wink:

So these are last lines? It did not restart after?
If so, please try to replace unless-stopped to always and check. Please disable your shell script.

Tried —always

No luck

An alternative solution would be to use the native binary instead of docker.

thanks @littleskunk , where can i get the native binary?

Then how do you have the first node configured? On the same machine? A different port? Or…?

My first node was setting up in Raspberry pi 4b. No termination for weeks.
Same installation to second pc ubuntu, get the docker termination. :<

Releases · storj/storj · GitHub, see the «Assets» section under each release.

BTW, I have to say that your problem is quite unique. For some reason your docker container is cleanly shut down, which suggests some additional tooling operating on the computer you run your node on. Unless you manage to provide some more clues, it will be difficult to offer you any advise.

then the first node should have a different external port, unless it has a different external address.

Do you have a watchtower running? If so - make sure that there is only one instance.
If not - please search for OOM kill messages in the system logs, because if container fail - the docker daemon should restart it.
When the container will stop again - please check that it is stopped and not deleted:

docker ps -a

If the container is deleted, then something external deleted it (not the storagenode container itself).


I had similar trouble in early days on my Synology-NAS. Back then the synology-internal Firewall was the problem. Although the TCP-Ports (and from a later Storj Version on also the UDP-Ports) were open the node started running perfectly. But somewhen it stopped working. The Docker Container itself did not shut down, but the Storj Node was all of a sudden currupt.
The solution was to open the firewall port Obviously Docker needs this…

Probably this won’t fit your current problem… So good luck anyways.