Node stopped after move of databases

I have followed this to move the database. When starting the node it has started a second and stopped. I have not been able to start the node again. I have copied the files to the root directory as it was before and the node has started without problems. On the board I see some satellites suspended at 86% and 93%. I have to worry?

Why didn’t the change from database to ssd work? Copy all the files from the root of the node’s data disk.

check the storagenode.log

This is repeated every several minutes.

2023-08-10T17:33:20+02:00 WARN console:service unable to get Satellite URL {“Satellite ID”: “118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW”, “error”: “console: trust: satellite "118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW" is untrusted”, “errorVerbose”: “console: trust: satellite "118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW" is untrusted\n\*Pool).getInfo:239\n\*Pool).GetNodeURL:178\n\*Service).GetDashboardData:188\n\*StorageNode).StorageNode:45\n\tnet/http.HandlerFunc.ServeHTTP:2122\n\*Router).ServeHTTP:210\n\tnet/http.serverHandler.ServeHTTP:2936\n\tnet/http.(*conn).serve:1995”}

Show log where it stopped for above :point_up: issue.

You can ignore this warning. This is an old decommissioned satellite of Stephan.

You not only need to move the databases when the node is stopped, but also specify the path to them either in the config.yaml file in the option storage2.database-dir: or with the parameter --storage2.database-dir in your docker run command.
The path to the databases should be available for user, who run storagenode.
In case of docker you need to use the path inside the container, and it should be properly mounted from the host. In case of binary (Windows/Linux GUI) you need to use an absolute path.

So, please describe what is variation of storagenode you are using - binary or docker, OS, and what you did, and what was the last error when you started the node and it’s stopped.

I have been checking. I am using the windows binary.

Modify the “config.yaml” file.
Added "storage2.database-dir: C:\Program Files\Storj\Databases"

I got “bandwidth.db” Heldamount.db" not found errors and other files.

I haven’t seen any other errors.

Is it possible that the path "storage2.database-dir: C:\Program Files\Storj\Databases"
It is not accessible due to some permissions problem?

Is there a tutorial that explains what to copy to move the database?

The board marks 100% suspension on all satellites.

Did you copy/move all *.db from the data location to "C:\Program Files\Storj\Databases" after storagenode is stopped?
And since your path contains space, you need to conclude it to quotes:

storage2.database-dir: "C:\Program Files\Storj\Databases"

Make sure to use a plain text editor such as Notepad++ to edit config, the word processors like Word or WordPad (even a regular Notepad) can broke it. Do not forget to save changes and restart the node to apply the changes.

If you moved your databases there, they should be available for the SYSTEM user, however, if it’s not - you need to change an owner to the SYSTEM user and grant it full write-read-delete-execute permissions.

that’s mean it’s recovered.

1 Like

Already solved.

I was copying the db and storage-dir-verification files.

I copied the database to the new location and it worked first time.

I always use notepad to edit config.yaml .

Thank you very much.

1 Like