Node suddenly not starting

Hello, my node suddenly didn’t start anymore and still refuses to do. It is no more reachable through the localhost. I didn’t make any changes whatsoever so I’m kinda confused. The Identity and key are still in the default location.

I’m working on windows and (as you can see) with PowerShell as administrator. I tried to restart the service which resulted in the attached error and also tried to use the net start which resulted in a system error 1067. Can someone kindly provide support for this?

Hi @blueflaeme
Please check the storagenode log file for the latest entries (How do I check my logs? - Node Operator ) and then post the last 20 lines or so between three backticks

log text

Thank you for your reply @Stob
I did as asked and retrieved the logs but got this result (I have no clue what it means but it doesn’t sound good)

Please find the trust-cache.json file and rename it. Then start the node again, it should recreate the file with the correct settings.

The longer version is this - FATAL Unrecoverable error {"error": "trust: malformed cache: invalid character '\\x00' looking for beginning of value" - #14 by peem

That seemed to fix it already because the dashboard is up again and node is online, that went a lot smoother than expected, thank you so much @Stob :slight_smile:

1 Like