Node went offline, no clue why

I have been running a node for nearly a year without any issues.

Checked the dashboard today and it said I have been offline for 3 days. I have made no changes since that time. For some reasons it just went offline. Said I was at 90% for almost every satellite.

Tried restarting the computer and that didn’t solve the problem. Dashboard says “offline” and QUIC says “misconfigured”

I tried running the storagenode.exe file from command prompt using “storagenode run” command and it says there is no wallet address or operator email. Both of those things are in the config.yaml file and have never been changed.

the storagdenode.exe file was last modified on 2/15

Help would be greatly appreciated. I really put alot of time into this node and would hate to lose it.

I get this error message when trying to run the updater

Okay. well because of this forum’s help over the last year on a number of different questions I posted I was actually able to somewhat solve the problem myself!!! I’m quite proud of my self…

Here is the error I got in my logs

So was the address I set up using the “no-ip” software and website. However, about a month ago someone on here told me I could just use the “DDNS” option on my internet router instead. So I set up an address under DDNS on my router and then changed the “contact.external-address:” in my config.yaml file to match the address I created under DDNS. Everything was working fine until 3 days ago when the node went offline. I’m guessing that’s because my IP changed and I let the 30 days run out on “NO-IP”.

I was able to get the node back up and running by logging into my account and re-activating

However, I made NO CHANGES to the config.yaml file. that is to say “contact.external-address” is still the address in my DDNS and NOT (

so here are my new questions for anyone that is kind enough to help me grow my knowledge base…

  1. how come storj is still looking for my node at even though it’s no where to be found in my config.yaml file?
  2. Is it truly possible for me to just use DDNS on my router so I don’t have to worry about reactivating NO-IP every 30 days?
  3. If the answer to #2 is yes, how do I set it up properly?

If you run your storagenode from CLI, you need to specify where it should search for config.yaml with --config-dir option, you also need to specify where is your identity files are located with --identity-dir option.
If you run without providing a path, the storagenode binary will search for config in the default location, for Windows it’s %APPDATA%\Storj\storagenode ($env:AppData\Storj\storagenode in PowerShell) and %APPDATA%\Storj\Identity\storagenode ($env:AppData\Storj\Identity\storagenode in PowerShell) accordingly.

So, my guess is that you have a config.yaml file in the default location, and it has this contact.external-address: inside.

The storagenode service is configured to search the config.yaml file in the C:\Program Files\Storj\Storage Node\\ location.
If you run your node as a service, then I would recommend to check the contact.external-address: in it. If you has changed the address, make sure to explicitly save the config, because Notepad++ will not offer you to do so and will be silently closed by click the close button. When you open it, you will see a changed value, but it will still be not saved to the file.
You can easily check that from the PowerShell:

sls "contact.external-address:" "C:\Program Files\Storj\Storage Node\config.yaml"

I guess I was running it as a service. I opened config.yaml using notepad as administrator and it was indeed the NO-IP address. I changed it to the DDNS and saved.

So to recap all you really have to do is make sure you change the “contact.external-adress:” using notepad as administrator and NOT by using notepad++?

It’s better to use Notepad++ or Visual Studio Code and click the Save button or menu File - Save. It will offer to open it as an Administrator, you should confirm and click the Save again.
And yes, changing the config.yaml in the C:\Program Files\Storj\Storage Node requires Administrator’s permissions by default.
After the change is saved you need to restart the service to allow it to re-read the configuration, you can do it either from the Services applet or from the elevated (as Administrator) PowerShell:

Restart-Service storagenode

services applet? Do you have a link for that?