Nodes stopped working

Anyone just had the services randomly stopped?
One of my windows nodes just stopped the service, the Rpi3b+ stopped and the container was not there anymore, and the Synology the same!
That’s weird!

No, my nodes are all still running. (2x RPi 2B, 6x Windows, 4x Linux Docker)

Did you have a power outage?

Did it try to update and failed or lost power?

No, but I realized that happened after the update to 1.5.2
I wonder if that has anything to do with it…it never happened before.

No, I didn´t do anything, just got Uptimerobot notification that 3 nodes went down.
When I tried to start docker, it said “no such container”.
Ran the run command and it´s all ok.

Automatic upgrade? Mine did it 9 h ago.

Probably but typically it upgrades and starts the service.

Happened for me as well. Actually I had same problem on previous update too. After that I had to make container again.
Alexey adviced to remake watchtower and so I did, but sadly it happened again on 1.5.2. I tried to pull logs but it seems that they got removed along with lost container.

Also had issue after 1.52 update on docker via watchtower. Only noticed as i was checking something else that service was down. Rebooted pi and all working again but all suspended at the moment.

Seems you node failed some audits.
I would like to suggest to search for GET_AUDIT and failed in your logs.

2020-05-31T16:20:52.389Z INFO Configuration loaded {“Location”: “/a pp/config/config.yaml”}
2020-05-31T16:20:52.398Z INFO Operator email {“Address”: " ------------ "}
2020-05-31T16:20:52.398Z INFO Operator wallet {“Address”: "--------------- "}
Error: Error creating revocation database: revocation database error: boltdb err or: open config/revocations.db: read-only file system
This was the error that kept on repeating itself until i did reboot. I can’t go back any further to see what happened prior to the error.

This is not related to the storagenode:

But as result you can fail audits, because this state is related to the disk corruptions and you can lost some pieces because of that.
I would like to suggest to check your disk for errors.

Ran the test but didn’t return any errors. Storj log showing get audits but no errors. Will keep an eye on it.
Is there a way to get notified if an update is about to be installed.

Please, use an automatic updates: