Nodes web api controller: illegal base64 data at input byte xx

Hi trying to run multinode dashboard binary , identity generated.

multinode --config-dir /home/ubuntu/storj_dashboard/multinode --identity-dir /home/ubuntu/storj_dashboard/identity/multinode run --log.level debug
2022-02-08T13:10:01.892Z	INFO	Configuration loaded	{"Location": "/home/ubuntu/storj_dashboard/multinode/config.yaml"}
2022-02-08T13:10:01.893Z	DEBUG	Anonymized tracing disabled
2022-02-08T13:10:01.931Z	DEBUG	db	Connected to:	{"db source": "file:/home/ubuntu/storj_dashboard/multinode/master.db?_journal=WAL&_busy_timeout=10000"}
2022-02-08T13:10:01.933Z	INFO	db	Database Version	{"version": 0}
2022-02-08T13:10:01.936Z	DEBUG	servers	started	{"items": ["console:endpoint"]}

Nothing is loged here.

On web browser receive “nodes web api controller: illegal base64 data at input byte 9” when trying to to add node.

/app/multinode add --node-id ************** --api-secret ************** --public-address ********** --log.stack --log.level debug
2022-02-08T14:59:16.105Z	INFO	Configuration loaded	{"Location": "/root/.local/share/storj/multinode/config.yaml"}
2022-02-08T14:59:16.106Z	DEBUG	Anonymized tracing disabled
2022-02-08T14:59:16.107Z	DEBUG	db	Connected to:	{"db source": "file:/root/.local/share/storj/multinode/master.db?_journal=WAL&_busy_timeout=10000"}
2022-02-08T14:59:16.107Z	DEBUG	Unrecoverable error	{"error": "illegal base64 data at input byte 26"}

Hello @fr33tk ,
Welcome to the forum!

Could you please try to stop the multinode and rename the database, then try to start again?

Thanks for response.
Seems that nothing changed.
Tried to remove db and then run again. Db is created

/app# ./multinode run --log.level debug --log.stack
2022-02-09T07:52:24.577Z        INFO    Configuration loaded    {"Location": "/root/.local/share/storj/multinode/config.yaml"}
2022-02-09T07:52:24.578Z        DEBUG   Anonymized tracing disabled
2022-02-09T07:52:24.595Z        DEBUG   db      Connected to:   {"db source": "file:/root/.local/share/storj/multinode/master.db?_journal=WAL&_busy_timeout=10000"}
2022-02-09T07:52:24.604Z        INFO    db      Database Created        {"version": 0}
2022-02-09T07:52:24.609Z        DEBUG   servers started {"items": ["console:endpoint"]}
/app/multinode add --config-dir /root/.local/share/storj/multinode --node-id=*********** --api-secret=************ --public-address=******** --log.level debug --log.stack
2022-02-09T07:57:45.053Z	INFO	Configuration loaded	{"Location": "/root/.local/share/storj/multinode/config.yaml"}
2022-02-09T07:57:45.054Z	DEBUG	Anonymized tracing disabled
2022-02-09T07:57:45.057Z	DEBUG	db	Connected to:	{"db source": "file:/root/.local/share/storj/multinode/master.db?_journal=WAL&_busy_timeout=10000"}
2022-02-09T07:57:45.058Z	DEBUG	Unrecoverable error	{"error": "illegal base64 data at input byte 4"}

Could you please show the version?

multinode version

This also looks like a docker container. Please, try to use a binary from the latest release.

Have already tried to run not on docker.
I am using binary files on docker.
Now current release

# /app/multinode version
2022-02-09T08:08:57.025Z	INFO	Configuration loaded	{"Location": "/root/.local/share/storj/multinode/config.yaml"}
Release build
Version: v1.48.2
Build timestamp: 08 Feb 22 13:15 UTC
Git commit: ef26ffe4d27d2b4192d07358f64ed65d8913f0dc

Yesterday was v1.47.3
Same problem.

What is your platform?

uname -a

I have a feeling, that it do not like provided API key. Could you request a new one and try to use quotes around it when passing to the multinode?

# uname -a
Linux 186ad8d89ffa 5.4.0-1046-raspi #50-Ubuntu SMP PREEMPT Thu Oct 28 05:32:10 UTC 2021 aarch64 aarch64 aarch64 GNU/Linux

Binary used

Could you also try to use a 32 bit binary?

Just tried to run
Ofcourse removing db before.

# /app/multinode add --config-dir /root/.local/share/storj/multinode --node-id=********** --api-secret=******** --public-address=***** --log.level debug --log.stack
2022-02-09T08:17:17.400Z	INFO	Configuration loaded	{"Location": "/root/.local/share/storj/multinode/config.yaml"}
2022-02-09T08:17:17.400Z	DEBUG	Anonymized tracing disabled
2022-02-09T08:17:17.404Z	DEBUG	db	Connected to:	{"db source": "file:/root/.local/share/storj/multinode/master.db?_journal=WAL&_busy_timeout=10000"}
2022-02-09T08:17:17.405Z	DEBUG	Unrecoverable error	{"error": "illegal base64 data at input byte 10"}

error code changed to illegal base64 data at input byte 10

Did you try to use a different API key (it’s generates a new one on each request)?

Yes numerous times, api key is generated each time new one.
Nothing changed, same error.

Is it working for you on x86 platform?

Just tried to run on x86_64 platform

# uname -a
Linux 9cfb5617274c 5.4.0-91-generic #102-Ubuntu SMP Fri Nov 5 16:31:28 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
root@9cfb5617274c:/app# lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.2 LTS
Release:	20.04
Codename:	focal
root@9cfb5617274c:/app# /app/multinode run --log.level debug --log.stack
2022-02-09T08:34:05.058Z        INFO    Configuration loaded    {"Location": "/root/.local/share/storj/multinode/config.yaml"}
2022-02-09T08:34:05.058Z        DEBUG   Anonymized tracing disabled
2022-02-09T08:34:05.059Z        DEBUG   db      Connected to:   {"db source": "file:/root/.local/share/storj/multinode/master.db?_journal=WAL&_busy_timeout=10000"}
2022-02-09T08:34:05.060Z        INFO    db      Database Version        {"version": 0}
2022-02-09T08:34:05.061Z        DEBUG   servers started {"items": ["console:endpoint"]}
root@9cfb5617274c:/app# /app/multinode add --config-dir /root/.local/share/storj/multinode --node-id=******** --api-secret=*********** --public-address=********* --log.level debug --log.stack
2022-02-09T08:37:38.568Z	INFO	Configuration loaded	{"Location": "/root/.local/share/storj/multinode/config.yaml"}
2022-02-09T08:37:38.569Z	DEBUG	Anonymized tracing disabled
2022-02-09T08:37:38.569Z	DEBUG	db	Connected to:	{"db source": "file:/root/.local/share/storj/multinode/master.db?_journal=WAL&_busy_timeout=10000"}
2022-02-09T08:37:38.570Z	DEBUG	Unrecoverable error	{"error": "illegal base64 data at input byte 10"}

maybe it is not platform dependent, I added 4 nodes today. Two were added successfully, two failed “Error: illegal base64 data at input byte X”, with X=20 and 30. Platform armv7. I can provide more info, but I am not sure if “secret” safe to share :slight_smile:

Is there any revelation regarding this issue?

you can put **** instead of secret

No. Nobody else has reported such weird issue on GitHub. Issues · storj/storj · GitHub
Asked the team.

i have the same problem on the latest release
I have

Remember my post here?

Now I have created an API key with the docker exec -it storagenode /app/storagenode info command. When I try to add the API data into multinode via Powershell cli multinode add then I get this error message: Error: illegal base64 data at input byte 17. I have tried 2 times and received this error both times.
Then I created the API secret with docker exec -it storagenode /app/storagenode issue-apikey and I was able to add it to Multinode with the same previous command instantly without error message.