Noob here! My node shows offline all the time. I have tried opening the port using static and dynamic

Just disabled the firewall and restarted the application. Still shows offline, port checker still shows it is closed. Looks like my ISP isn’t allowing these… Looks like I am running out of options haha. If it is ISP, then I don’t have a choice as this is the only service I get here… lol. I might not be able to run a node :frowning: Thanks a lot for your assistance. Really appreciate it.

Yes, DDNS looks fine if you say the IP is the same. Where did you allow port 28967 through the router?

Yeah, looks good assuming node Internal IP is Maybe Windows Firewall/Anti-virus?

Temporarily try to disable the Windows Firewall? Then run the port check.

This is my rule for TCP and UDP:


Please, search for WAN IP on your router (usually it’s on the first page after login) and compare it with IP on
If they not match, the port forwarding will not work.

Yeah, it shows different, You are right. I checked with my ISP and they have zero clue… Tried 3 different routers, still the same… :slight_smile: Finally, I am giving up on this. If I can’t figure this basic setup, I might not be able to figure out any issues in the future… :frowning:

Thanks everyone for helping and apologies that I gave up after all your assistance, I tried my best. Good luck everyone!

1 Like

I’d like to know what kind of internet connection that is medium-wise (cable, vdsl/fiber/wireless?)

You can try to call to your ISP and ask them for public IP, you can say that you need an access to your security IP cam from anywhere, this will allow you to do not explain Storj.
The other way is to switch a ISP to the one who offer a public IP, it could be dynamic but must be a public (WAN IP match the public IP on yougetsignal).
And the last option is to use VPN with port forwarding option such as, ngrok, PIA, AirVPN, PureVPN, etc.

Thanks a lot. I will check this out.

It is Fiber. Thanks.