Offline node problem and port forwarding

Hi. I’ve spent half a day trying to get my new node online. Although I spend many years with GPU mining, Storj requires a good chunk of networking knowledge. Hope you all could help me on this rather basic question.

I use x to indicate numbers

My set up is simple: Router > unmanaged switch > Win10
The setting for each step is

1. Router
1.1 Port Forwarding
Local ip: 192.168.1.x
Local port: 28967
Protocol: TCP+UDP
Remote ip address: 100.x.x.x ( ip address given when I registered for DDNS at noip.com)
Remote Port range: 28967

1.2 DDNS
I also set up the noip within my router. The router indicates that it’s synconized.

2. Unmanaged switch
I don’t think there is anything to do with this part

3. Win10

  • I follow all the main guide. identity set up and verified.
  • Put the firewall exception rule for inbound. TCP@28967
  • Get to the dashboard but it’s shown as offline. Also try to change the inbound rule to allow all port all protocol but still the same
  • No IP DUC program for Win10 is installed. It runs normally.

Using the https://www.portchecktool.com/

  • Put in 100.x.x.x ( ip address given when I registered for DDNS at noip.com)
  • Put port 28967

My questions are

  • Are there anything wrong with these inputs and set up. Any advice on fixing this port forwarding issue
  • After my change in setting, how do I apply setting to the node. Will the node pick up the communication after the port forwarding set up by itself, or do I need to restart PC/ type command line
  • what is a difference between IP given by noIP and my public IP address.

You don’t use the no-ip IP, you have to use the hostname that you have registered with no-ip.

Also you need their ip updater: https://www.noip.com/download?page=win

I would try with firewall off to make sure the firewall is not interfering.

The ip updater will take care of updating your ip. You will enter your no-ip in the nodes config as ip.

Check also here: No-IP changing IP address?

The idea is: The local ip updater detects any ip change and informs the DDNS service about your actual ip. Anyone calling your DDNS hostname will then receive your actual ip from them and can connect to you.

1 Like

Welcome to the forum @alphatio!

Use https://www.yougetsignal.com/tools/open-ports/ instead so you can test if your No-IP hostname is correctly working. Enter your hostname instead of IP.

That’s not necessary if the router already does that, which seems to be the case.

Thank you for your reply. This is what I’ve done

  1. Change the setting in config file
    the public address of the node, useful for nodes behind NAT
    contact.external-address: XX.ddns.net:28967

  2. Turn off window firewall

  3. The noIP DUC program was already installed and run normally.

  4. I change router setting to
    Local ip: 192.168.1.x
    Local port: 28967
    Protocol: TCP+UDP
    Remote ip address: ANY
    Remote Port range: 1-65535

The port is still not forwarded. Now I’m using https://www.yougetsignal.com/tools/open-ports/ to check by insert XX.ddns.net with port 28967

True. But maybe a good idea to test?

You should always test everything with your public ip before moving forward with a ddns service to make sure nothing is affecting the outcome. Also You need to make sure to forward the port to the correct computer ive seen many times of not forwarding the port to the correct pc.

Are you sure your provider supports port forwarding?

It’s resolved for port forwarding. My provider has their own DDNS service provided for user for free.
After I use that instead of noIP, it works and online now.

I feel a very great vibe in this community. Thank you for your quick and enthusiastic support :slight_smile:

3 Likes

Certainly one of the best communities available. And I know Dogecoin. :wink:

1 Like