Сonfiguration Mikrotik

Tell me, please, can someone set up Mikrotik for the Story node? What are the features. We found out experimentally that packages are lost through Mikrotik. If you release it directly to the network, then everything is fine. Routing Settings:
Mikrotik 951Ui-2HnD
chain=dstnat action=netmap to-addresses=192.168.1.19 to-ports=28967 protocol=tcp dst-port=28967 log=no log-prefix=""
chain=forward action=accept protocol=tcp dst-port=28967 log=no log-prefix=""

Thank you in advance.

Hi, use destination NAT instead of netmap.

Her is example from Mikrotik wiki:

Destination NAT

Forward all traffic to internal host

If you want to link Public IP 10.5.8.200 address to Local one 192.168.0.109, you should use destination address translation feature of the MikroTik router. Also if you want allow Local server to initiate connections to outside with given Public IP you should use source address translation, too.

Add Public IP to Public interface:

/ip address add address=10.5.8.200/32 interface=Public

Add rule allowing access to the internal server from external networks:

/ip firewall nat add chain=dstnat dst-address=10.5.8.200 action=dst-nat \ to-addresses=192.168.0.109

Add rule allowing the internal server to initate connections to the outer networks having its source address translated to 10.5.8.200:

/ip firewall nat add chain=srcnat src-address=192.168.0.109 action=src-nat \ to-addresses=10.5.8.200

2 Likes

That’s right:
chain=dstnat action=dst-nat to-addresses=192.168.1.19 to-ports=28967 protocol=tcp
dst-address=60.60.89.85 dst-port=28967 log=no log-prefix=""
chain=srcnat action=src-nat to-addresses=60.60.89.85 src-address=192.168.1.19 log=no
log-prefix=""
?

1 Like