OS Drive crashed - How to use existing /home and /storj

Had my OS drive fail yesterday and had to reinstall the OS from scratch, experience has taught me to put /home and apps on additional disks, so I still have 9TB of /storj data and my .local/share/storj/identity/storagenode/ folder.

Do I need to setup the new docker storage node considering I am using the prior keys and disk? Will this result in me losing the 9TB of data I have pulled down over the last 2 years?

I tried skipping this step and running the node, but I am getting the error “bind source path does not exist” - this makes me think need to run the setup again …

You shouldn’t have to run the setup step again.

If you still have the identity and your files, you should be able to run the node software and get back in business.

Double check your paths.
I assume the /storj folder contains all the node’s databases and customers’ data?

1 Like

When I moved a node to other machine, I stared the setup steps, pointing to a clean location and the old identity. Than copy with overwrite the old node in the new location, or just modify the paths in docker run, if you don’t want to copy, and keep the data where it is.

I used /storj for simplicity, but it’s close

Files are here…

root@appserver:/10TB/storj# pwd
root@appserver:/10TB/storj# ls -alX
total 72
drwx------ 4 root  root   4096 Apr 13  2021 orders
drwx------ 6 root  root   4096 Feb 16 19:37 storage
drwxrwxr-x 4 cpare cpare  4096 Feb 16 13:29 .
drwxrwxr-x 8 cpare cpare 20480 Apr 22  2022 ..
-rw------- 1 root  root  32768 Feb 13 18:56 revocations.db
-rw------- 1 root  root   2730 Feb 16 13:29 trust-cache.json
-rw------- 1 root  root   8504 Apr 13  2021 config.yaml

When trying to start the node however I am getting

root@appserver:/10TB/storj# docker run -d --restart unless-stopped --stop-timeout 300 \
        -p 28967:28967/tcp \
        -p 28967:28967/udp \
        -p 14002:14002 \
        -e WALLET="0x36C43347221E42CaD5aF218eF045af011d41955f" \
        -e EMAIL="chris.r.pare@gmail.com" \
        -e ADDRESS="parehouse.asuscomm.com:28967" \
        -e STORAGE="9TB" \
        --mount type=bind,source="/home/cpare/.local/share/storj/identity/storagenode/",destination=/app/identity \
        --mount type=bind,source="/10TB/storj/",destination=/app/config \
        --name storagenode storjlabs/storagenode:latest
docker: Error response from daemon: invalid mount config for type "bind": bind source path does not exist: /10TB/storj/.

perhaps you need to change the owner of this mount point to root, since you run it as root.

1 Like

Still having the same issue after setting this to root:root, I guess I need some help with what steps need to be completed when building a replacement node and maintaining the data I have already stored. I really don’t want to start a new node and go back to no stored data…

How did you mount this drive?
Please show result of the command:

df --si -T


grep "/10TB" /etc/fstab

Not sure why, but mounting the disks under /mnt solved the problem for me - I am back up and running, unfortunately with only 93% uptime for this month…

Usually related to permissions for the root folder. The /mnt one has correct permissions to allow mounting.
But could be the reason is using leading numbers (not letters) in the root folder name…
The online score should fully recover after 30 days online.

1 Like