Out of the blue my one of my nodes does not gets no traffic and ERROR contact:service ping satellite failed + failed to dial storage node

When I look at the logs i see:

ERROR contact:service ping satellite failed {"Satellite ID": "12rfG3sh9NCWiX3ivPjq2HtdLmbqCrvHVEzJubnzFzosMuawymB", "attempts": 2, "error": "ping satellite error: failed to dial storage node (ID: 12iBDANzFBWxuUm8P7s6epzNNZHCAXTGnfEWyNoHoTg28LydBJe) at address bg:28971: rpc: dial tcp 145.133.244.18:28971: connect: connection refused", "errorVerbose": "ping satellite error: failed to dial storage node (ID: 12iBDANzFBWxuUm8P7s6epzNNZHCAXTGnfEWyNoHoTg28LydBJe) at address momserver.hopto.org:28971: rpc: dial tcp 145.133.244.18:28971: connect: connection refused\n\tstorj.io/storj/storagenode/contact.(*Service).pingSatelliteOnce:141\n\tstorj.io/storj/storagenode/contact.(*Service).pingSatellite:95\n\tstorj.io/storj/storagenode/contact.(*Chore).updateCycles.func1:87\n\tstorj.io/common/sync2.(*Cycle).Run:92\n\tstorj.io/common/sync2.(*Cycle).Start.func1:71\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57"}

And repeat

To me it seems like my router with my node setup as DMZ has actually no problems with storagenode 2 and 3 but storagenode 4 seems to be failing as of a couple hours ago. it seems like not the right port is being set open to the outside, because I did a portscan and the other nodes have their respective ports open but storagenode4 not. The settings are identical except the ports of course.

docker run -d --restart unless-stopped --stop-timeout 300
-p 28971:28967
-p 127.0.0.1:14002:14002
-e WALLET=“x…”
-e EMAIL=“x…”
-e ADDRESS=“momserver.hopto.org:28971
-e STORAGE=“12.5TB”
–mount type=bind,source="/mnt/storj16TBv2/storj-identity4/",destination=/app/identity
–mount type=bind,source="/mnt/storj16TBv2/storagenode4/",destination=/app/config
–name storagenode4 storjlabs/storagenode:latest

I am running on fedora 33. I’ve tried chaning the ports and resetting the router. To no avail. What can I try to get this node offline?

Have you signed the identity? The satellite would refuse to talk to a node that hasn’t signed its identity.

Yes the identity is signed.

[user@localhost storagenode4]$ grep -c BEGIN /mnt/storj16TBv2/storj-identity4/ca.cert 
2
[user@localhost storagenode4]$ grep -c BEGIN /mnt/storj16TBv2/storj-identity4/identity.cert 
3

I fixed this by resetting the router again (hard reset)
And secondly I put back the original config.yaml file.

Can’t reproduce the error again.

Not good external address. Please, make sure that’s correct address, also check is it updated to your current public IP?
You can check your current public IP there: https://www.yougetsignal.com/tools/open-ports/
Also check your port forwarding rule on your router, it should forward 28971 either to the 28967 in case a different PC or 28971 in case of the same PC. Check your port mapping option in the docker run command in case of docker (it should be -p 28971:28967 if you forwards to 28971) or server.address option in the config.yaml in case of binary.
Please, also check your firewall rules as well.