Passphrase and bucket

Hello everyone,
I’m facing some issues during creating bucket, And more, I always logged in using my email I’D ,Password and at the home page I add Passphrases. But at every time I see this thing which you can see image in below as well as I can not create bucket, it show “Missing fields in request.” error.

Screenshot (16)

@munjalp did you get the “success” popup after creating/generating the passphrase? After the success popup you should see the “Create a bucket” button appear on your homepage.

1 Like

@prernaparashar Yes, I get that popup when I enter passphrase but when I refresh it or load it then it again ask me for generate new passphrase again and again every time. Now, I’m manually adding buckets using uplink cli. And I’m trying to open that bucket(s) then it through this error “Missing fields in request.”. Just like I uploaded 2 images.

This usually means some applied limitations either to your browser (like forbid cookies or access to local internal storage in your browser) with some extensions (some adblockers for example) or applied security filters to outgoing connections (something simple blocking our domains).
I would recommend to use a different browser or disable these extensions or at least try to clear cookies and cache.
It should remember encryption phrase in the secure local storage in your browser and it will vanish when the session is expired or when you refresh the page.
So, yes, after every refresh of the page it will ask you to provide an encryption phrase to encrypt/decrypt your objects. If you uploaded some objects, then you need to provide exactly the same encryption phrase used during upload otherwise your objects cannot be decrypted and will remain locked.
Please note, the encryption phrase is used to encrypt/decrypt your objects in any bucket and it’s unrelated to your password for the login account.

1 Like

Yes, I acknowledge with your answer but since I created an account I use same passphrase every time. And it shows me this “Missing fields in request”. Even I tried to create new bucket it shows me a same popups. Is there anything else to do?

Yes, this error is appear because of some blocking of required services (our domains and/or cookies and/or local secure storage in your browser).

Please try to use a different browser or mobile internet (in case if blocking is happened on your router and/or ISP).

1 Like

Thank you @Alexey, what should I do for unlocked to object which is locked in side the buckets because I am using same passphrase which I used to locked or add data into bucket but now I can not access it with the same passphrase.

the “locked objects” stanza is a visual interpretation for objects, uploaded with a different encryption phrase (or partial uploads).
You may unlock them using the encryption phrase used for them. Or you may check your partial uploads with the command:

uplink ls --partial sj://my-bucket

or, if the current encryption phrase doesn’t match a previous one, in encrypted form:

uplink ls --encrypted --partial sj://my-bucket

or just

uplink ls --encrypted sj://my-bucket
1 Like

@Alexey @prernaparashar Well, I understood that concept but I am saying that I can easily create buckets, add object inside bucket and also remove and download object using uplink CLI. But my main point is that, that I can not open my bucket from website whenever I try to open it always ask me for either create new passphrase or switch passphrase. And , as I mentioned before, Since I created an account I am using same Passphrase.

Some browsers or extensions may block the satellite UI from functioning properly, sometimes it’s even on ISP side.
The uplink will work in this case anyway, but in browser you could have issues.
Earlier there was no cache at all, so even switching between buckets required enter your previous encryption phrase. Now it cache it until you refresh the page.
However, if something blocking this functional (like blockers in the browser or too restricted access with forbid to store cookies for example), it will likely ask for encryption phrase even if you switch between buckets.
I wonder, if you enter your encryption phrase, can you see objects? Or do you see another error?
Because if bucket looks empty and only “locked objects” there, then either encryption phrase is wrong, or something blocking functional on this site.

Did you try to use a mobile browser?

1 Like

Ummm Yes, I tried in other 2 browsers.
And I can see my buckets as well as buckets object but I can not access it and there is something which let me not access my buckets, Even I also can not create bucket from the web application.
I acknowledge with you that I can easily creating buckets and add data using uplink CLI that’s means uplink working properly 100%.
And Thank you for replying @Alexey

In this case the blocking part could be your router and/or ISP.
Please try also to use the mobile browser and mobile internet.

What satellite by the way?

1 Like

@Alexey I’m using Chrome as browser .
Okay then let me try in mobile, In case if I can get access via mobile then I’ll inform you.

Chrome is your browser, but you have registered on some satellite., or depending on the selected region.

1 Like

@Alexey My satellite is

I see. I saw some reports from time to time about blocking our domains in China. If you are from China, it could be likely the same issue and could be solved with VPN.

1 Like

Hello @Alexey , This “Missing fields in request.” is still occurring.
I’m not from China and I checked many browsers as well as I also tried in mobiles and also tried VPN. Is there anything else to do or to understand?

I cannot reproduce that on any browser and any connection, this is very weird.
Could you please open a developer console (F12 in chrome), select console at the bottom and refresh the page. When you would see an error, please take a screenshot and post it here.

1 Like