Pi 4 - Terminal stuck on first Docker Run of "Running a Storage Node"

Good evening! I am new to Raspberry Pi 4 and Linux, but a power user of macOS since 2006 so I’m familiar with Terminal in general. I feel like I’m on the last step of getting this node setup and running, however I appear to be stuck on the final step of getting this node started. Under the Storage Node page section, “Running the Storage Node” is where I get stuck.

Screen Shot 2021-07-11 at 9.43.36 PM

After setting up the commands and arguments to run the docker program, terminal does not appear to process the command, and instead inserts a “>” with a new line, not outputting any information or indication that the command is running. repeatedly doing this just keeps making multiple lines of:


" (etc)

This is a Raspberry Pi 4, with 4GB ram, hooked up on ethernet and setup with noip2 service to work online behind my Xfinity router. I used the app to forward port 28967 to the device. I am using a “4 TB” external drive but GParted says it’s actually “3.64 TiB” Is there any information beyond this command that my Pi can give out to help figure out what is wrong? Am I using the right amount of GB in my arguments for not going over that 10% threshold? Included is a cropped screenshot of what happens after I press Enter. Any help would be greatly appreciated so, thanks in advance:

 docker run -d --restart unless-stopped --stop-timeout 300 \
-p 28967:28967/tcp \
-p 28967:28967/udp \
-p \
-e EMAIL="[redacted]@proton” \
-e ADDRESS=“[redacted].hopto.org:28967" \
-e STORAGE=“3270GB" \
--mount type=bind,source="/home/pi/.local/share/storj/identity/storagenode",destination=/app/identity \
--mount type=bind,source=“/mnt/sda1”,destination=/app/config \
--name storagenode storjlabs/storagenode:latest

I had this once but was not able to figure out the cause for that behavior. I had copied a working command from another node and it refused to work on the new node.

But what I did was to paste the command line by line and then it worked. Needless to say the line breaks are not required and you can try without them in one line.

Hello @foxball ,
Welcome to the forum!

Seems you used some wordprocessor to form your command, it replaced straight quotes " to a curly ones and .
Please replace all curly quotes to the straight ones back, the curly quotes instead of straight ones, hyphens instead of double dashes and so on are not valid for the terminal.
When you form the command please use only plain text editors, even Notes would try to break your command.

1 Like

It does that because one of your quotes isn’t matched. So typing the closing quote will get you out of that mode. (or ctrl-c)

Thanks everyone. I did not realize that when I was copying and pasting between VNC sessions, that the direction of the quotation marks would mess something up like that. One character can make all the difference in Linux. I was using notes on Mac so that must be where the formatting came from. I am assuming the default text editor on the raspberry device is just plain text only?

In either case… After changing only the quotation marks did everything start working suddenly! And now I can monitor it on the go with VNC with my phone or Via the terminal application or VNC on my Mac so I don’t need to walk between rooms; it is currently a headless set up. Much appreciated!

You doesn’t need a UI to control your Pi, it’s waste of resources for honestly.
You can use a remote ssh connection and it’s more secure than VNC: How to remote access the web dashboard - Node Operator

OK. I’ll turn off the VNC. I don’t think I need to SSH remotely, just look at it from within my LAN. Thanks for the tips and help. 15GB stored so far on my “4TB” drive. Maybe by end of year I’ll upgrade to a 10TB external drive after finding a relative article.