Port forwarding issue


I feel kinda dumb asking this question because there are so many video’s online on how to do this but I can’t seem to figure it out. I set the port I need on my router to the local IP address of that computer but it still can’t connect. Below are some screenshots. I have a ZTE H369A.

I use Open Port Check Tool to see if I can make a connection but it can’t and I don’t know what I’m doing wrong. After I opened a port and directed it to the local IP address of my workstation it should work.

Why do you forward port 443? You need port 28967 TCP and UDP. See Port Forwarding - Node Operator

This is the port that noip.com requested. There is also a port open on 28967 in the same manner.

What IP/hostname did you specify in the config.yaml?

Can you confirm that your storage node’s local IP is actually

Yes, the computer from where I’m doing the port check has the IP of I even locked it in the router to the mac address and checked it multiple times.

I never used a config.yaml though, that is just the settings for my computers IP, right?

This is the config file for your storage node software.
Wenn installing via GUI installer, the installer will fill the config.yaml for you.

If you aren’t running Windows that does not apply, but in that case you should’ve pointed out that you aren’t running Windows :wink:

I haven’t gotten that far because I wanted to forward a port first so I could set it correctly in the installer. I am running windows :wink:
But like I said the port checker website still says the port is not open so I doubt Storj software will tell me otherwise.

Of course, if no service is listening on that port then the port will appear as closed from the outside. Start your node and check again.

Where did you read that noip.com needs port 443 opened inbound to work? You should remove this as people will have access to this PC if a webserver is running on that port. The same applies to Remote Desktop. I’ve seen in your screenshot, that you opened this port as well. This is very insecure. https://www.cloudflare.com/en-gb/learning/access-management/rdp-security-risks/

You should rather connect through a VPN to your LAN and remove unnecessary port forwardings if you need access to local resources from the outside.

1 Like

I will check if that works. I didn’t know a device needs to listening to test it. Nobody mentions that in their tutorials… :confused:

Those other ports are all default settings on my router, I didn’t add any ports other than the two I mentioned.

Somewhere in the tutorial on noip they ask you to open this port. I’ll change the number to something else then. :slight_smile:

Ok, then I misread your screenshot. These seem to be preconfigured applications in your router which you didn’t assign to an active port forwarding. Just delete the noip port forwarding by clicking on the trashcan symbol on the very top of your screenshot.

Alright, I’ll take a look at it when I get home. I’ll let you know how it goes, hopefully this is fixed now :grinning:

Thanks, the issue is fixed! I was something really simple but I couldn’t figure it out.