Port forwarding on new router

So I recently got a new router and under port forwarding settings I see a couple of options I hadn’t seen in the previous model.

I’m unsure as to how what needs to go under the destination port range and destination, can’t find the info in the installation docs. Would love some help, thanks.

Hello @rocesar,
Welcome to the forum!

Please, remove this filter.
You need a port forward rule actually (it could be under “Virtual servers” or “NAT”).
You also can Google your router model with “port forwarding” clause - and find exact instruction for your router.

1 Like

Hi Alexey,

Thanks!

I’ve been searching all over the place for that clause but I just can’t seem to find it I even called up my ISP’s tech support and they directed me there. Will keep looking.

Do you have a make and model for your router? This would help point you in the right direction.

Sure, it’s a ZTE F680 rounter/modem

You need to enable this setting

  • Enable it
  • Name = Storj01
  • Protocol = TCP
  • Wan Host Start = “Leave blank”
  • Wan Host End = “Leave blank”
  • Wan Connection = “Name of your Wan Connection from drop down list”
  • Wan Start Port = 28967
  • Wan End Port = 28967
  • Enable Mac Mapping = untick
  • Lan Host IP = “IP address of your storj node” 192.168.1.4
  • Lan Host Start Port = 28967
  • Lan Host End Port = 28967

Then Add

I know nothing about this router, but I think that will make it listen on your WAN IP address on TCP port 28967, and when a request comes in will NAT and forward to LAN IP on port 28967 which should be storage node.

Once this working, if you want you can change the public TCP port, but make sure you update the docker run command - would get it working with basics before play.

Hope that helps :slight_smile:

Hi CutiePie

I must have different firmware as the menu I see differs from the screenshot you proivided, it looks incomplete, here’s a screenshot.

I can’t seem to find the same menu when I google it so I’ll give my ISP another call and report back.

Thanks for your help

Looks like you can navigate to the User-End Device tab and register to access latest firmware and documents:

Their site is very finicky, I registered but when I navigate to the firmware listed I get an error message that states:No permission. I’ll try again a bit later.
Also, I don’t see where I’d upload the firmware to. It’s not under system or account management and the status tab only displays the Device info. I feel like my ISP is screwing me over with a limited custom firmware. I got on the phone with tech support again and they pointed me to the same IPV4 filter which clearly isn’t the right spot. The rep could not explain why the port forwarding option is not there and only recommended I contact their customer support department to see if maybe I could get another modem.

That might be ISP specific firmware. I really don’t like when they do that, but my ISP does it too. I think you might need to look under the internet tab. These features are often listed under WAN, but since I don’t see that listed on this submenu.

I tried that as well, nothing there unfortunately. I’ll have to give customer support a call and hope they can switch out the modem for something that isn’t as locked down as my current device. I’ll slowly starting to hate my ISP, there’s no reason why to block such a common feature.

Please, click on “Internet” at top menu and show screenshot, what is here

2 Likes

As I can only upload one image:

Status => WAN shows the WAN connection status I can only renew or release. No editable info here

Security => Firewall - Can adjust the firewall level from High to off

Security => Filter Criteria - Here’s where tech support initially pointed me to (specifically to IP filter - IPv4)
There’s MAC, URL filter, and IPv6 filter

Parental controls - Not there

And finally:
SNTP

I feel like I’ve looked everywhere but if anyone has any insight I’ll be happy to take another look. Thanks!

Looks like your modem has been nerfed by your ISP. I found this screen in a forum showing that the Port Forwarding option should be under Internet -> Security -> Port Forwarding

I have (in ancient times), gotten around ISP feature blocks by finding the internal URL of the page I wanted and manually navigating there. It would be a long shot, but if you can figure out the URL pattern maybe you can get there. That is assuming a different URL shows up for each configuration page. Might require using a page inspector and viewing the iframe for the sub-tabs. Definitely grasping at straws here.

3 Likes

Maybe it’s also possible to flash the original ZTE firmware for that specific router. In case the nerfed firmware will not checksum the uploaded firmware file of course…

1 Like

I had an idea. I’m not sure if this would work, but you could try and use software that opens the port via UPnP. Even if they disable port forwarding, the router must support UPnP or almost nothing would work. I have no idea if this software can also auto-renew the port mapping (as UPnP port maps tend to expire), but maybe that could be scheduled as well. A bit of a hack job work around though:

This post provides some examples (although beware they link to an old/outdated page for the miniupnp project). This might be more work than you want to go through though.

It is a good suggestion and I’d give that a try but that feature is also missing, can’t seem find where I’d upload the firmware to.

In case you still haven found the setting, here’s a screenshot from my ZXHN H298A

I sure hope not if there is no way to turn it off.

UPnP has a LOT of known issues. I do not recommend turning it on.

That’s to be expected. If you don’t own the modem, which is almost certainly the case, you’re not going to be allowed to flash your own firmware. You could get in trouble with your ISP if you manage to do it anyway. I don’t advise going down that route.

Hello someone can share wan settings page but ajax link, first need go wan settings page, and then open dev tools click again on wan settings link and on dev tools (chrome) network will show request something like this:

http://192.168.1.1/?_type=menuData&tag=optical_info_lua.lua&=1615440102XXX

thanks

Caa