PORT fowarding, router problem

Hello everyone,
i’m totaly new in the STORJ community but i think it’s awesome and i wanted to try myself to be a node operator.
I have good knowledge in informatique in general, (i have a university degree in informatique and electronics). So i wanted to start slowly and prepare every thing and then upscale my storage capability.
But i had a little? Problem when i need to forward my PORT. I’m living in France and my routeur tells me that i can’t “use” or “forward” a port under 32768 exactly “you need to chose a port superior to 32768”, so it’s impossible for me to root the port 28967 like asked with my routeur ?
Can someone help me with this ?
Thank you all !!

Welcome to the forum.

If you are using Linux you just change the docker run,
28967:28967 to *****:28967.

If you ate using Windows i think that you can change it in config.yaml.

Or if you can open let say 55555 and point it to 28967 in your router setting

I actualy did this, external port 33124 and internal port 28967, and everything else is configured with the 28967 port.
Now, i had à problem telling me that i didn’t had enought right to install the storage Node. I reinstalled everything, now averything seems to work fine, but i can’t access to the dashboard, “connexion failed”. And in services “Storj V3 storage Node” wont launch, when right clicking and “start”, it says "
windows could not start the Storj V3 Storage Node service on local computer.
Error 1067: The process stopped unexpectedly."
And i’m on Windows server 2019 btw.Storj PB

Please, enable firewall and dnscache service.
Don’t forget to add an inbound rule to the firewall for the 28967 TCP port.

1 Like

Do what @Alexey said and i hope thats solves it for you.

I have only started nodes on Debian so there are ppl in here way better then me in that.

1 Like

No problem John.A ! Thank you for your help !
And i already did what you asked Alexey, i followed the step by step guide of STORJ, Firewall and DNScache are already enable by default and i think i have properly set up the inbound rule in the firewall.

Please, show the last 20 lines from the log: https://documentation.storj.io/resources/faq/check-logs

Hm, could this be related to my port fowarding in the router ?
I’m using “no-ip” of course, my dns is ****services.sytes.net:28967, and i tipped so when installing Storagenode .!

You can edit config.yaml file and contact.external-address should look like

contact.external-address: services.sytes.net:28967

Then restart the storagenode service.

1 Like

@nerdatwork thank you, now it’s working, I must have made a mistake when typing the address on the installation. Now my status is “Offline” on the dashboard, have i something else to do ?
I checked the logs and i have a “Heldamount service error: node not found : 1nGHoHe7tg1AedGkcC2vnfnAFcEV1WFe1dhyVXc62PMyjyQb5R”.

If you are offline the nodes port is Still closed. Try to find where.

Is your DUC started?

Indeed, beacause i had to enter a different external port in my router, here 33524, i had to enter this port on the config.yaml after my DNS address, now i’m online, thank you all for helping ! :smiley:

1 Like

One last question, in my logs i have some “upload canceled”, is this a problem or not ?

It’s not a problem its by design. There are 2 reasons for upload canceled messages.

  1. Your node lost the race for the piece.

  2. Your node didn’t get acknowledgement for the successful upload which is incorrectly shown in the log. A fix for this is in the works.

Make sure you don’t see download failed and GET_AUDIT error messages. Also you should redirect your log to a file else log gets deleted when you restart your node.


Okay, it’s nice to see it working ! And thanks for the tips,

Also you should redirect your log

but i don’t know how to do that, do you have a link or somewhere i can find how to ?


1 Like

Perfect !
Thank you again ! :smiley:

1 Like