Port Open, Cert correct, but QUIC offline and misconfigured

I’m having problems with QUIC, but ports are open:


I’m fighting this monster since yesterday =/

Now, I’m trying to re-do all steps, even a new cert after erasing the old ones

I’m runnig it in docker

And I already have other node, running at a complete different port, in other device.

Does somebody can help this poor soul, please? =D

Just a wild guess, but you are open TCP, quic is based on UDP, could you check on that? (usually on port forwarding page on router, usually there is an option to choose tcp/udp or both).

1 Like

Wow, thanks for your lightning fast answer!

This is the rule redirecting ports from my wan (ISP router) through my personal router (OpenWRT):

Now that I open it, I saw “destination” set to LAN, but actually it should be wan (because Storj talks to my wan address).

You seek the way like a hunter dog, my friend haha

I changed it and now have to wait the new Certs to be done rsrs

1 Like

Yep, it didn’t work =/

There is a couple thing I’d like to check, first on your ISP WAN setting could you verify the WAN IP address you are getting is the same as when you use this command: curl -4 ifconfig.io (some ISP use CGNAT).

Secondly, I don’t understand this (I’ve never use a setup like your - this is just based on my puny understanding router). If you have both ISP router AND personal router, the ISP router should be in bridge mode (usually on page WAN configuration) and ALL configuration will be on your OpenWRT (I’ve never done that - let be clear), so earlier you said:

That doesn’t look correct? Shouldn’t OpenWRT do the work here? I actually out of wit here, hope someone have done it clarify it for me too.

1 Like

Yes, you’re right with your guess. The ISP’s router should be put in bridge mode (most likely with a phonecall to ISP), than all the config and the wan connection should be made on his own personal router.
Bridge mode makes the router transparent for traffic, it’s just an interface addapter from ISP’s cable to home network.
Than, as port forward rule, I think he got it. I’m not familiar with OpenWRT interface, but yes, it must be opened to wan.
Source wan ipv4 and destination lan.
ipv6 should be disabled for now. It’s a security risk and storagenode dosen’t use it for the moment.
Also, disable DDOS prevention and UPnP. First one is interfering with storagenode, second one is a security risk. Don’t enable acces to router interface from wan or ssh or telnet, also.
If the bridgemode is enabled and the settings are correct, you should see the WAN IP in your OpenWRT interface, not a LAN IP. Give both routers a restart first, after all settings are applied.
Quick, on the other hand, can be ignored; on some setups works, on some dosen’t.
You could try that from arrogantrabbit’s post; maybe works for you:
–server.address=“LAN IP:28967” \


This is correct, the destination for incoming traffic is WAN → LAN → Node.

That’s correct, so you need to make two port forwarding rules: on the ISP router to your router and on your router to your node. Or, as suggested by @kocoten1992 you need to switch the ISP router to the bridge mode.

actually it can use it, just not a lot of traffic from the customers on IPv6, and the satellites uses only IPv4 to communicate with nodes and also advertises only IPv4 for the clients who uses a native connection, you may have an IPv6 traffic only from GatewayMT instances at the moment.