Portforwarding | Windows 11 | Third node

Dear all,
it is the third node that I am installing on the same network. The other two are older and work fine.

  1. Oldest node listens on 28967

  2. Second node listens on 28968

  3. Third node does not work. I have tried to use port 28969 without success and port 28966 without success.

I have checked the firewall configuration and it is pretty much the same thing I have done with the other two nodes, besides the port numbers of course.

I have performed a port scan via the site canyouseeme.org and I it confirms me that port 28966 is closed. I have done a local scan with application for android called NetAnalyzer of the ports and apparently on this computer the port open is 28967. Port 28966 is closed.

Windows firewall is disabled. In any case I have added the rules as per instructions, by using the powershell command.

From what I see the program storagenode.exe still uses port 28967. I have already tried to change it to 28966, restarted the pc, but nothing changes. I have set it back to 28967 because, maybe it is correct that it stays that way.

What else can I try?

I have checked the configuration.yaml file and I have those two entries:

the public address of the node, useful for nodes behind NAT

contact.external-address: myipaddress:28966

public address to listen on

server.address: :28967

Any suggestion?

contact.external-address = tell clients where to find you, you show port 28966
server.address = the actual location of your node, you show port 28967.

You are telling clients to reach you via an IP:port that doesn’t work. The third node shouldn’t start because that port is already in use.

1 Like

Thanks. I have changed:

public address to listen on

server.address: :28966

And now it works.