Problem updating storage node from 1.5.2 to 1.6.3

I’ve got the aforementioned problem. Received couple of emails about need to update my node to version 1.6.3. This instruction ( doesn’t help: “docker pull storjlabs/storagenode:beta” says “Status: Image is up to date for storjlabs/storagenode:beta”. Should I wait or there is another way to update?

If you are running watchtower - let it update your rig. You don’t have to do anything for now.

The update process can take up to 2 weeks, windows nodes first, then linux beta image, just wait until watchtower does the automatic upgrade

Thanks for help. I’m running watchtower, just sometimes use manual approach to ensure I’m not in “trouble”. Was a little worrying about this “If you don’t update it soon it can affect both your reputation”

Try storjlabs/storagenode:latest

There appears to be a bug in v1.6.3 so the release was halted. As far as I can tell, Storj has not begun rolling out any more updates at this time.


That’s good to know, thanks :slight_smile:

Tried that. Much the same result. Since the modem times “waiting” is the best grace.

Those mails should not have gone out… The roll out was halted, so it’s correct that you can’t update right now.

1 Like