Problem with permissions on docker syno box node

I’m trying to setup a 2nd node on a different synology which will run on a different subnet. This syno is the one where I first had my one and only node running until I moved it to another syno. So, it shouldn’t be hard… but something’s not going well…
I followed “Storage Node | Storj Docs”, put my 6 identity files created and signed in a macbook in . Created an empty . setup the storage node and immediately I get a error: “failed to check for file existence: stat config/config.yaml: permission denied”. I run the node anyway, but it keeps restarting and showing the same error.
I don’t recall doing anything permissions wise when I first created my first node.
Can anybody help?

Yep. I was getting same error on my Synology.

Synology Docker version has something special about how it handles file permissions.

Anyway, I just did
sudo chmod 777 data
Problem solved.

What is “data”?
Is it a file? A directory?

that’s <storage-dir>

Well, I could never understand the synology mess with permissions…
If I ssh into it (main user belonging to admin group), all files that don’t start with “@” have 777.
If i become root, the same files that were 777 become 000.
I have no idea what’s going on…

Ok. Just in case someone else have the same problem…
I ssh the NAS and changed the ownership of the storj directory to my main user (which was the user that installed docker and created the directories… don’t ask!). Next, I changed the permissions (which were rwxrwxrwx, but couldn’t really be…) to rwxrwx___.
Now, all is well…
The funny thing is that now all of the files in the NAS are showing permissions correctly for all the files, even when I become root…

– commands –
sudo chown -R $USER storj2/
sudo chmod -R 770 storj2/

where “storj2” holds both the “identity” and the “storage” directories.