Prometheus Storj-Exporter

here’s the output you asked for:

For comparison I ran the same query on the :1.0.9-beta3 image that is working on the Rpis, but unfortunately that seems to be the same results…

Had the same issue with this python error on my Raspberry.

Found this with Google:
https://github.com/linuxserver/docker-papermerge/issues/4

You need a updated version of libseccomp2, 2.4.3-1 or higher. It is currently not available for Raspberry PI OS, but it is for Ubuntu. You can look into downloading the Deb from Ubuntus repository.

&

Thanks! As the docs states, downloading and installing a newer libseccomp2.deb works for RPi4.

wget http://ftp.us.debian.org/debian/pool/main/libs/libseccomp/libseccomp2_2.5.0-3_armhf.deb

sudo dpkg -i libseccomp2_2.5.0-3_armhf.deb

This version 2.5.0-3 no longer exists, but i found the current version 2.5.1-1 here:
https://packages.debian.org/search?keywords=libseccomp2

Now it works with docker! :grinning:

Hope this mixing breaks nothing somewhere else on my Pi.

4 Likes

Thanks for the investigation.

I facing with the same issue. Will give it a try during the day.

Confirmed

I deployed the package from https://packages.debian.org/sid/armhf/libseccomp2/download, and all works now.

Hey kind of weird question, but will vetting come back to the exporter after v 1.22.2 stopped working

Thanks.

It was removed from storjnode api and if/when it comes back then exporter will support it.

3 Likes

In the mean time the earnings calculator will pull this info right from the db’s, so that still works.

1 Like

yes it does but I loved the visual on centralized display

1 Like

I know, but it’s just temporary. It’ll be back in the API soon I hope.

2 Likes

I released an update of my combined dashboard for the exporter and log-exporter:

1 Like

Just for info. I’m currently moving to an IntelNUC and with version 1.4 of the Boom Table Plugin for Grafana, some lines in the node summary table are broken. Unfortunately I forgot to make a screen. With version 1.3 it works as usual.

Yes that is a known issue, that’s why all our tutorials/how-to include the version 1.3 of the boom table plugin

Just pushed v1.0.13 with this fix in. latest images updated for all platforms.

4 Likes

Hi,

I followed the Quick start guide for the dashboard. (Storj-Exporter-dashboard/quick_start at master · anclrii/Storj-Exporter-dashboard · GitHub)
But There isn’t getting any data in the dashboard.

If i try with curl ( curl -s 172.16.100.250:9651/metrics) , i’m seeing the stats, so the api is available.

Does anyone know what’s going wrong?

Best regards,

Ronnie

I just made some progress, i can add an external node without problems.
But i can’t get the node running on the same host as the exporter get to work.

Any idea’s?

yes when you are in the config .yml create another target with 127.0.0.1:port

It works for me, though make sure you have net lopback enabled

I already tried that.

It looks like my prometheus docker container can’t connect to that port.
I tried localhost, i tried the internal ip, and i tried the docker ip.

On the host itself al the options are working, but in the prometheus container i get a connection refused.

yo sorry I’m experienced with Windows so This is the most advice I can help sorry

this is the guide I followed, although I’m sure a lot of the same information was put onto @greener’s github page.

How do you run your exporter and how do you run your node? I you used docker run command for each of them they each run in their own separate networks unless they run in host mode.

You can create a network with both containers in it such that they can talk to each other.

docker network create [choose name i.e. storj-exporter]
docker network connect [network name you chose] [storj container name or ID]
docker network connect [network name you chose] [exporter container name or ID]

Thank you very much.
That did the trick :slight_smile:

Finaly a way to monitor all my node’s in one dashboard :slight_smile:

2 Likes