QNAP APP install

just trying to set up the QNAP APP as I’ve loads of space to use. I keep getting the same error on install and can’t seem to find any answers anywhere?

[App Center] Failed to install Storj Storage Node 1.1.0. You must first install and enable container-station >= 1.7.2041.

anyone got any ideas ???

Hello @rtknight,
Welcome to the forum!

You should install the Container Station first. This app is a wrapper around the docker.
When the Container Station is installed you will be able to start the application.

1 Like

Hi, it doesn’t appear in my APP center. Maybe my QNAP is one of those not support.

If you have an ssh access to your NAS, you could try to download the docker image to your PC, extract a binary and transfer it to the QNAP, then run it there.
You also can take a look on these threads (you can build the storagenode yourself):

I ran into a similar problem.

  • Installed Qnap container station
  • Got the Qnap package installed and configured
  • Clicked on update node.
  • Clicked on Start Node.

The Storj container got added and tries to start, but container just cycles running / stopped.

@HabaneroGabe -

What version of the app are you using?



V1.1.0. It was a link off your install guide.

That one is very old - please check-out Releases · storj-thirdparty/qnap-storagenode-app · GitHub.


Looks like the v1.1.0 is the release.
I went ahead and installed the v1.1.2 prerelease.

Now when i open the storj app, i just get a white screen. I went ahead and uninstalled the storj app and reinstalled the v1.1.2 prerelease. The storj app still opens to a white screen.

Uninstalled v1.1.2 and reinstalled v1.1.0 and storj opens fine again.

Ah in the docker console, i see this error:

Error: Error starting master database on storagenode: group:
–stat config/storage/blobs: no such file or directory
–stat config/storage/temp: no such file or directory
–stat config/storage/garbage: no such file or directory
–stat config/storage/trash: no such file or directory

Can you verify the correct path for your storage directory?

On the app i have it mapped to /share/STORJ/Storage.
That location is valid.

Then i check the container settings and they seem to match the settings in the storj app.
/app/config /share/STORJ/Storage Read/Write

I would recommend to use a CLI instead:

Hello @HabaneroGabe

Can you please send some screen shots and can you please confirm path of the installed app is something like “/share/CACHEDEV1_DATA/.qpkg/STORJ” and check if there is web folder is there or not as you are getting white screen that means you don’t have proper settings for the apache and php may be . So it look like some environment issue. If you wish you can reach us to parag@utropicmedia.com and karl@utropicmedia.com so we can help you run the app in your QNAP .