QNAP NAS - identity error - The identity files don't exist at the path selected. Please create identity or copy the identity folder at the given path

Hello,

This is my first node trying to install but I am having this issue. I can not start the node because of doesn’t found the key.

I was following these tutorials:

https://documentation.storj.io/dependencies/identity
https://documentation.storj.io/sno-applications/qnap-storage-node-app

Also I have the ID with my email and I generated the key with my laptop.

But I think I am missmatching something. Anyone had the same problem? How can I to solve it?

Appreciate the help.

Hi @enrique -

Look in File Station to make sure that the identity files are at the path you selected in the app. Can you share screen shots of both FIle Station(expanded to show the directory tree of your identity files) and the path selected in the app?

Hello,

There is the files, I was reading another post and the problem is similar mines. But still I can not execute de wizard correctly.

I tried several direcotries with the identity files. The last one is:

And the files in this directory are:

Thanks you very much for the help. Sorry for the late response but I had to reconfigurate the QNAP again, but still I am stuck with the same problem.

The last error when I try to start the node is:

LATEST LOG :
6f79178249b1 storjlabs/storagenode:beta "/entrypoint" 8 hours ago Created storjlabsSnContainer

Hello

You can try with /share/Public/Identity/storagenode

1 Like

It is my config
you can replace Storj2 by Public

I’m not sur than use the directory “Public” it’s the best idea

1 Like

Thanks for the help I think now is finding it!

But still not working, now seems that the container not able to start.
I have the port forwarding and If I open the port 8080 I can login in to my QNAP. ¿What am I missing?

Thank you very much for the help! I am a little bit closer!

Could you take a screenshot of Containerstation, the logs , the parameters …

I am not sure how can I see the parameters, but I tried tu start the container manually in the container station and the error gave me was:

image

I think that I miss somenthing with the ip’s and port because I did not configure the 0.0.0.0:8080.

How can I manage to change this settings?

Thank you

You need to specify the different port for the storagenode container. The default port is 28967, so, please, use it. The 8080 port is used by something other.
I have no QNAP on my hands so, I cannot guide you through UI.
It’s much simpler to just run a CLI setup instead of any GUI, just login via ssh: https://documentation.storj.io/setup/cli/storage-node

Hello,

Thanks for the help. I configured one container before and it was causing some incompatiblities. But still not working.

Currently I am having the same problem that the below formun.

I saw we have to change de command to launch de docker, but I am using a QNAP and I don`t know how to change or solve this issue.

Thank you very much

QNAP app is outdated and doesn’t execute the setup command:


You need to execute it once to create all needed folder structure.

great a little bit further. Now I am having a problem with the identity, I launched this command

docker run -d --restart unless-stopped --stop-timeout 300
-p 28967:28967
-p 127.0.0.1:14002:14002
-e WALLET=“0xxxxx”
-e EMAIL="xxxxx@xx.com"
-e ADDRESS=“xxxx.ddns.net:28967
-e STORAGE=“3TB”
–mount type=bind,source=/share/Public/Identity,destination=/app/identity
–mount type=bind,source=/share/home/StorjData,destination=/app/config
–name storagenode storjlabs/storagenode:latest

I created the identity and put it on /share/Public/Identity/storagenode but it is not finding it. Where do I have to move it? /app/identity Where is this path?

Thank you very much for the help.

Since you put your identity to

thus you need to correct your docker run command a little bit

to

--mount type=bind,source=/share/Public/Identity/storagenode,destination=/app/identity \

Also make sure to do not use any word processors to form the docker run command - they converts double dash -- to hyphen , straight quotes " to curly ones like and , those symbols are not valid for the command line. Thus please use a plain text editor instead, for the bash it’s nano.

This is the process for install the docker Storj sur QNAP

1- In first delete ALL container Storj Local

2- Create Docker
you can create STORJLABS/STORAGENODE

image
replace “/Storj2/” by your folders

image
GOARCH is empty
ADDRESS is your IP or your domaine name
you can take yourdomain.ddns.org or yourdomaine.ddns.org:28967 if you have a problem

Click “Create” and go to “OVERVIEW” in Containerstation for start the Docker

After, if your node run correctly you can install the docker watchtower for the automatic updates
https://documentation.storj.io/setup/cli/software-updates

With this procedure there is no reason that your node does not work.

And I forgot, start by removing the QNAP STORJ application, it doesn’t work well and I think it’s obsolete.
Also delete all Storj containers already created.
I spent a lot of time with this application and lost a lot of time.
I have 3 nodes and made at least 10 to 15 installations before I fully understand how it works. The simplest is the procedure I just described.

Yeii I am online!!

Thank you @Alexey for your knowledge. And @vincetheblack for the final manual very use friendly and undestable.

Thanks a lot I think I anderstand better storj.

regards,
Enrique

@enrique @vincetheblack Please, do not use a GUI! You can lose the node using it!
The reason is simple - any GUI on any NAS is used dangerous option -v to mount storage to the container instead safe option --mount type=bind. The outcome of -v option is - if your disk is not mounted for some reason, the -v option will create an empty temporary volume to store customers’ data!
When the container got deleted, the temporary volume will be deleted too, include customers’ data. Thus your node will start to fail audits and finally can be disqualified.

The current version of the storagenode should stop, if the data mount point doesn’t have a special file and structure which are created only on setup, however, if you run setup in the second time, when the mount point is empty you can start the node and node could be disqualified for losing customers’ data.
So, please, be extremely careful, if your working node which you run via GUI is occasionally stopped and complains about missed special file and/or structure - do not run the setup in the second time!

Ok, thank you for the advice.

I will follow the manual update guide for stop and restart the container but with the rights commands. I am seeing that the containers launched with beta version of storagenode so I will try again with the latest.

https://documentation.storj.io/setup/cli/software-updates?_ga=2.185912809.1946148851.1613294682-79675880.1610996600

Anyway I launch the docker setup previously with the commands you post above.

Is there any good practices for the restart of the container?

Thanj you very much @Alexey

Hello @Alexey
Thank you very much for your help and involvement.

On my Qnap the volumes are not deleted when I delete the container, this is already a good thing. Before I put watchtower on, to upgrade I would delete the container and then create a new one, luckily my volumes have never been deleted.

Is there a docker command to know how the mounts were done?
How does Watchtower do the update? Removing and re-installing a container or updating Storj inside the existing container?

Translated with www.DeepL.com/Translator (free version)

@Alexey Ah I just found
Docker inspect [containername]

And I have this:

image

C’est bon ?