QNAP StorJ Node destroyed, reinstall not working

Dear Support,
I can’t get my sotrage node to run anymore.


What happened:

  • Storage node updated to version 1.55
  • Qnap updated to 5.0.0
  • Dashboard tells me what is misconfigured for QUIC
  • Forward port for TCP and UDP on the router
  • Forward port for TCP and UDP for the Docker container
  • Container crash … reboot and cant find identity.cert.

What have I done:

  • I don’t even remember what everything

In the end I came to the decision to reinstall the node. I still have the data and my certificates.

  • Uninstalled StorJ app (1.1.0)
  • Removed all StorJ containers
  • Reinstalled Container Station
  • Reinstalled StorJ app (1.4.0)

Qnap tells me: Application installed correctly and can be used. Now when I open the application I just get a blank white page. I was hoping the setup process would start and I could set the previous settings and the node would start working again.

What do I have to do to reinstall the node on my QNAP?

Warm greetings

Same with StorJ App 1.3.0.
Blank white page after install App and open it from Qnap App Center.

No Containers recreated in Containerstation.
I am not sure if that happens during installation of the App, or during the Setup process of the App.

best regards


StorJ App Version 1.1.0 seems to work with my QNAP NAS.

I have installed App Version 1.1.0.
Open it from App Center an the Setup was configured like before. After i recovered my certs I get my Storagenode online.

A new Container was created. Node Version shows 1.55.1 with QUIC misconfigured.
Now I have to forward the UDP Port in the Container-Station settings.


Hello @Vossi ,
Welcome to the forum!

Seems only that version is working on your QNAP.
I usually recommend to use docker directly following the guide CLI Install | Storj Docs, but if you made it running, then you can continue to use the app.
Make sure both protocols are configured in the port mapping of the container.

Hi Alexey, thanks for your reply I will tackle the Docker CLI installation in the future. But I think I’ll wait until my node is back on the satellite with 100% online status.
I now had downtime for 2 days because of the error.

I can’t set the port forwarding for 28967/UDP at the moment. As soon as I want to set the rule for the Docker container and I activate the checkbox “Do not apply settings by restarting the container”, the NAT rule is not applied. :frowning:
I also don’t want Docker to kill my running container because of a NAT rule, that was what caused my previous error.
If I stop the node via the app, the Docker container no longer exists. Only the Docker image, but I didn’t find anything there regarding any default parameters for a container. I could create my own container for the image there, but I don’t know if the app recognizes this and then starts it and not simply launches a second container with the image.

If someone could tell me in which configuration file on the NAS the default values ​​for the container are defined, I could probably configure the NAT rule for the UDP port there.

best regards

This is a normal way, how docker containers works - to update any parameter you need to stop and remove the container and run it back with all your parameters include changed ones.
With the ssh and docker CLI you will use the command to run the container similar to:

docker run -d --restart unless-stopped --stop-timeout 300 \
    -p 28967:28967/tcp \
    -p 28967:28967/udp \
    -p \
    -e EMAIL="user@example.com" \
    -e ADDRESS="domain.ddns.net:28967" \
    -e STORAGE="2TB" \
    --mount type=bind,source="/replace/to/your/actual/path/to/the/identity",destination=/app/identity \
    --mount type=bind,source="/replace/to/your/actual/path/to/the/data/location",destination=/app/config \
    --name storagenode storjlabs/storagenode:latest

I found a solution …

QNAP seems to store the application data in the following path:


There I found an interesting shell script:


Looking into that shows the start command for the Docker Container:

cmd="docker run -d --restart=always -p ${PORTADDR}:28967 -p ${IPADDR}:14002:14002 -p ${IPADDR}:9000:9000 -e WALLET=${2} -e EMAIL=${6} -e ADDRESS=${1} -e STORAGE=${3}GB -v ${4}:/app/identity -v ${5}:/app/config --name ${CONTAINER_NAME} storjlabs/storagenode:latest "
cmd="docker run -d --restart=always -p ${PORTADDR}:28967 -p ${IPADDR}:14002:14002 -p ${IPADDR}:9000:9000 -e WALLET=${2} -e ADDRESS=${1} -e STORAGE=${3}GB -v ${4}:/app/identity -v ${5}:/app/config --name ${CONTAINER_NAME} storjlabs/storagenode:latest "

Know I have checked, how to set the protocol for the published ports with parameter -p.

After that was clear i edited the two line with the docker command from:
cmd="docker run -d --restart=always -p ${PORTADDR}:28967 …
cmd="docker run -d --restart=always -p ${PORTADDR}:28967/udp -p ${PORTADDR}:28967/tcp …

Open the App, press the start button and tada the container forwards 28967/udp for the new spawning container.

best regards

1 Like

Hi Alexey,
thanks for the information. I had no experience with Docker until now. But I’ve wanted to take a closer look at it for years, but I have too many other tasks on the screen.

The solution is OK for me for now. Until a problem occurs again, I’ll start with the native Docker solution.

Any idea why my container is still forwarding 9000/tcp? I think this is the interface for the QNAP app. but I’m not 100% sure yet.

The restart parameter also differs as I can see.
–restart unless-stopped sounds safer than in my config. The QNAP app starts the container with --restart always. I still have to find out what the parameter does exactly in the documentation. :wink:

best regards

What version of QNAP are you currently using?

Hi Alastran,
sorry for the late reply.
As read in the first post:

Best Regards