QNAP TS-251D — Scratching my head for over a week

I have QNAP TS-251D and it had 1TB HDD and 2GB of RAM. Then I went ahead and bought 4TB HDD and 8GB RAM.

Went through all the setup guide and process without luck (the first one was the beta version and the second one it’s the latest from Github).

Forwarding port was the issue I thought and bought ASUS RT-AX55 and added these settings:


Then when I try to create identity I’m getting this message:
The identity files don’t exist at the path selected. Please create identity or copy the identity folder at the given path.

I used Browse feature to select the folder which is /Public/identity and I also used SSH to get correct (I’m assuming its correct) path, which is /share/Public/identity

But I still get the above message after the process. Also Authorization Token field becomes empty.

I also followed this guide Identity - Storj to create the identity on my Mac Mini M1 but all I got is stuck at sudo mv identity /usr/local/bin/identity with error that the identity doesn’t exist.

Help please :slight_smile: and thanks

Please, generate an identity on your PC/Mac, authorize it and transfer to your QNAP.
Remove the Storj QNAP app and use the CLI method instead: CLI Install - Storj
It uses docker, so you need to have a Container Station enabled. To be able to execute commands, you need a ssh, so install/enable it too.
When you get a command prompt - follow the guide: Storage Node - Storj

1 Like

Thanks Alexey. Identity process is currently running on my PC. Will update this post again, after I went through all the steps.

Finally got it working but can’t reach the dashboard because I entered 127.0.0.1 in docker run command.

When I check the dashboard with CLI I can see that it works but I can’t access the dashboard on my NAS IP.

Any suggestion?

Remove 127.0.0.1 from you docker runt command, just have the port 14002. Then go to qnap IP:port

1 Like

Thanks for the suggestion. I did try that but it says it’s already being used. I don’t want to stop the storagenode and don’t know how to change that while it’s running?

Fixed it following a guide from @baker on this link:

Thanks

1 Like