QUIC is misconfigured

QUIC is configured
Port forwarding is enabled - on router as well as on firewall
NO-IP is configured in router
storj service is set to hostname

all the results were good according to the articles I have followed here.
Need help understanding what piece did I miss here or I didn’t followed properly.
Kindly help

Sometimes even my nodes give the Quic misconfigured. I think it depends on the high I/O. Restarting the node should fix it, at least that’s how it happens to me

I believe there is a ‘check-in’ repeated after the node startup, so even if you left it, it should correct + connect on the next check-in

1 Like

Essentially you need both TCP and UDP forwarded and open. If you made changes recently, you’ll want to restart your node as the check happens at start up.

Hello Knowledge,

Great to hear from you as I have configured the Node watching the video from you on YouTube.
I have forwarded the port on my Router for both UDP and TCP, also created the firewall rule for both of them.
Have also performed “restart-service storagenode” multiple times which did not change this.

If there a medium or logs through which we can identify the actual situation.


Thank you for your response Roberto what is the way to identify the I/O and I have already restarted the StorageNode Service multiple time which is not happening now.

Well, the node won’t know what is blocking the port, it just knows that it hasn’t received communication. Ate you running Windows as your OS? You mentioned a router and a firewall. Do you have a physical firewall device or are you talking about Windows Firewall?

  1. Router has NO-IP configuration which is successfully configured as per the articles.
  2. Also, port forwarding is setup on the Router
  3. I have assigned a static IP to the computer which was changing hence leading to add another port forwarding again and again
  4. I am using Windows 10, though I was taking about Windows Firewall
  5. Also, My router has a Firewall which is set to recommended
  6. Storaj Node is pointing to the hostname created as requested in the article

Please suggest and let me know if there is anything more you need to know.

Is your node working other than Quic? If so, TCP is likely setup correctly but somewhere your UDP is either not forwarding or being blocked by the firewalls. If it were me I would disable the Windows Firewall and see if that solved it. (You have to restart the node to recheck Quic). If that doesn’t do it, I would look at your firewall in the router and see if you need a rule to be added for UDP.

If you added both TCP and UDP rules to the Windows Firewall, then it will not block UDP traffic, usually it’s done by router and some security extensions on it.
I would not suggest to switch the Windows Firewall off, but switching off the firewall on your router instead, because it’s likely the case. And any DDoS protection features too, if it have it.

Hello Alexey & Knowledge,

I have first turned off firewall from the router completely.
Then tested by restarting the node it is still same.

I have also turned off the Windows Firewall and still same.
Also turned off Windows Defender and checked by restarting the nodes.
Checked and still same.

Please check the attached screenshot.

You are offline, in my opinion the problem is the ports. What ports have you assigned to the node and which ones have you opened on the router?

Port Number 28697

What is the range for in this configuration? I see the WAN, and then there is a range, and then it looks like the node’s IP, and ports. That range might be the incoming range? In which case it should be essentially wildcarded. What router brand/model is this?

1 Like

Can you check the box “WAN-TR069” that is currently selected. Can you set external or something similar that sets this port forwarding to all incoming traffic?

Right now you basically said it should forward the port 28967 to if the incoming address is in between and
Basically a Port forwarding that only works from devices within your own network.


Also make sure that you don’t have multiple entries for the same port going to different IP’s.

Thank you Guys for helping me find out the resolution.
I’m finally online and QUIC is also in OK State.