QUIC Misconfigured in v1.67.1

Hi there,
Since v1.67.3 is running, QUIC is back again with no changes in my network configuration!
Thanks to the StorJ team for fixing this issue.
Regards, atxjl :sweat_smile:

I have four nodes and two are showing QUIC as Misconfigured. I use Uptimerobot and no alarm. I also perform a page refresh every day or a few days.

Today I noticed that nodes with Version 1.67.3 and 1.67.1 have QUIC Misconfigured whereas the two nodes still on Version 1.66.1 have QUIC as OK.

It sounds like version 1.67.x has a bug.
Has anyone else seen this?

This has been talked about before - QUIC Misconfigured in v1.67.1

Ctrl+F5 in browser fixes dashboard display issue if no other problem exists.

Thanks, I had even rebooted but the recommendation worked.

Thanks again for the tip.

Whould be great if CTRL+F5 will double the income too :rofl:


I pressed F5 several times.

I have also stopped and restarted the container several times.

I’m still getting QUIC misconfigured sometimes. It does say 1.67.3 now though

It’s really like pulling a slot machine with the reload button or F5 on my browser. Sometimes it says okay, sometimes misconfigured. Usually online, but occassionally offline.

I now have red warnings for suspension and online…


If you have warnings on suspension score - you need to check your logs to figure out why your node failing audits,

the online score perhaps affected by node restarts, so you need to figure out what’s going on with your node, because right now it looks like unrelated to the bug QUIC Misconfigured in v1.67.1

I guess now is a good time to explain how the QUIC configuration check works starting from the release of v1.67.1.

We reimplemented how the QUIC check is done and that was introduced in this commit: storagenode: overhaul QUIC check implementation · storj/storj@59b37db · GitHub.
The commit message explains at high level, what was wrong and what we did to fix this.

The current implementation blocks the the startup until one or none
of the trusted satellites is able to reach the node via QUIC.
This can cause delayed startup. Also, the quic check is done
once during startup, and if there is a misconfiguration later,
snos would have to restart to node.

In this change, we reuse the contact service which pings the satellite
periodically for node checkin. During checkin the satellite tries
pinging the node back via both TCP and QUIC and reports both statuses.
WIth this, we are able to get a periodic update of the QUIC status
without restarting the node.

To be clear, it makes sense that a hard refresh changes the QUIC status. You don’t need to restart the node unlike before this change was introduced. We are reusing the contact service which periodically sends a checkin request to the satellite. The satellite then tries to ping back the node via both TCP and QUIC. If any of the satellites fails to ping back the node using QUIC, the dashboard will show the misconfigured status message which could also mean that your node was offline or checkin failed and will be retried or the UDP service port is actually misconfigured.


7 posts were merged into an existing topic: QUIC misconfigured and node status offline

The v1.67.3 didn’t help with the QUIC issue.

hello after update 1.67.x my quick is reporting mis configured I have using the same run cmd for docker for the last six months and the dashboard has reported always quick ok

thanks for the info it fixed it

I suddenly have the quic misconfigured error, refresh made no difference and it showed misconfigured on multiple nodes.
Now just as sudden, the problem is fixed.
I think the “MISCONFIGURED” word is unhelpful. Suggest “offline since x” in the case where it switches from good to bad?

Hi @andrew2.hart, thanks for your suggestion. I agree with you that the “MISCONFIGURED” status might be unhelpful for such cases. Do you mind opening a GitHub issue on this?

Nothing has changed on my router config and Mac computer. Updates of StorJ node are performed via “watchtower” docker container… StortJ v1.72.5 is now running:

  • Looking at server status page ( via Chrome.app on my Mac shows a red “Misconfigured” QUIC alert.
  • At same URL location via Safari.app, it shows a green “OK” QUIC message?!?

I have tested UDP access (port:28967) at https://check-host.net/check-udp. It replies “Open or filtered” for any host trying to connect to my StorJ node.

My problem was solved after rebooting my Mac. Then, everything seems to be correctly working (Chrome/Safari):

Hope this can help community!

You may just hard refresh (Ctel-F5) your browser. The QUIC status is now checked on each check-in (1h by default).

Hi Alexey,
Do you have the key sequence equivalence for MacOS X?
[Ctrl][F5] doesn’t work on my Apple® computer ([Ctrl][F5] works on Windows OSes).

[CMD] + [R] for Macs