Raspberry pi wont boot after editing fstab

Hello,

i wanted to copy my files to a bigger driver.
The problem is that when im follow the raspi guide https://support.storj.io/hc/en-us/articles/360026612332-Install-storagenode-on-Raspberry-Pi3
my raspi wont reboot after editing sudo nano /etc/fstab.
My server worked 5 months with the same command. Now its not working anymore.
I got the problems with raspi 3 and 4.

Greetings

Edit: I can repair fstab.

well, usually there’s always the possibility of encountering dragons when modifying the boot record of a drive.

Do you get a grub stage 2 bootloader screen when starting your system? The thing which lets you select which kernel to boot?

I repaired it but the question is how do i automount my storagenode. Maybe the guide has to be edited? Because 5 months earlier it worked with the same raspi.

not sure what you mean by repaired it. if your system is booting, the the outcome of running the boot record modification tool fdisk has not contributed to any of the issues youre seeing.

then my bet would be that you edited /etc/fstab is a slightly wrong way with regards to the extra storage disk you are auto-mounting. Because the other option is you edited the rootfs mountpoint wrong, or the proc, boot mountpoints wrong.

If it was an edit corrupting rootfs, boot partition mountpoints, the system wont start. Whereas if you edited the extra storage mountpoint wrong in fstab, then at next restart your system will hang before starting up for up to 5 minutes looking for ways to mount the drive over the network.

i dont see any issues in that guide besides the static /dev/sda1 /mnt/storagenode ext4 defaults 0 2 example theyre giving. the drive letter in your case might very well be different. e.g. /dev/sda2. furthermore, it makes more sense to mount drives with their label, which you can obtain by doing ls -la /dev/disk/by-uuid/ and then looking up the syntax in /etc/fstab of how the rootfs is mounted with a uuid label

Thanks for the help. I noticed that my external drive is “/dev/sda1 256 976746239 976745984 3,7T 7 HPFS/NTFS/exFAT” and i used “/dev/sda1 /mnt/storagenode ext4 defaults 0 2” from the guide. So maybe it works if i change ext to ntfs?

can you please provide the output of fdisk -l /dev/sda here

Device Boot Start End Sectors Size Id Type
/dev/sda1 256 976746239 976745984 3,7T 7 HPFS/NTFS/exFAT

yeah, so you have an ntfs partition on that drive. i would like to say it is highly unrecommended to run ntfs. the forum is littered with issues around ntfs drives. otherwise youre correct. the quick and dirty way of mounting it in fstab would be /dev/sda1 /mnt/XXX ntfs defaults 0 0

notice the 0 0 at the end instead of the 0 2. and again, this is a quick and dirty way. the ntfs filesystem is highly undesirable for high throughput disk ops under linux. a better way to mount it would be to specify a bit more options that make it play nicer with linux

UUID=0AC4D607C4D5F543 /mnt/volume ntfs-3g async,big_writes,noatime,nodiratime,nofail,uid=1000 [OPTIONAL U NEED TO LOOKUP USER IDs],gid=1000 [OPTIONAL U NEED TO LOOKUP GROUP IDs],umask=007 0 0

most importantly, u really need to add the async,big_writes,noatime,nodiratime options to the mountpoint

Ok thanks. Still have a backup of my server files so im going to format my new drive to ext4. Thank you a lot.

1 Like

glad to hear youll move to ext4. good luck!