Rclone does not show tardigrade or storj as an option


I am following the rclone with native integration article in the docs, but rclone does not show either tardigrade or storj as a backend option.

Specifically, I do:

$ rclone config
$ n #for new

When I need to enter the type of storage to configure storj or tardigrade are nowhere to be seen. Here’s a gist with the list of options I get: list_for_rclone.sh · GitHub

Here’s the rclone version in case it matters:

rclone v1.53.3-DEV
- os/arch: linux/amd64
- go version: go1.15.4

Thank you.

Welcome to the community! Please follow the step by step instructions in our documentation for setting up Rclone with hosted gateway or Rclone with native integration. You will have to have set up a Storj DCS account on storj.io beforehand.

I noted you’re using v1.53.3, perhaps you can try downloading the latest v1.57.0 version? I can confirm that has Storj/Tardigrade as an option.

Thank you for your input. The link you gave (Rclone with native integration) is the same one I gave and followed in my question.

I also have a Storj DCS account, and can run:

$ uplink access list
=========== ACCESSES LIST: name / satellite ================================
accessnm / XXX...XXX@eu1.storj.io:7777
$ uplink mb sj://music
Bucket music created

It seems it was a problem of using an older version of Rclone (the standard debian one installed with apt). I installed rclone with curl https://rclone.org/install.sh | sudo bash and that did the trick.