Reputation.db doesn't exist

lol managed to create a database file… O.o i think its about time i just stop trying semi random variations to get this to work… xD this is exactly how i usually end up breaking a linux install…
didn’t have any luck with this command, am in the right folder tho and ls shows the reputation.db file…

now i keep getting syntax error… :smiley: … i suppose i can just delete the db right?
that should restore it…

tried to run that
sqlite3 --header --column reputation.db “select hex(satellite_id), audit_total_count,audit_reputation_score from reputation;”

seemed to work fine until i got to creative on the parameters and ways to get it to work…

then i got this when i ran it.
-bash: syntax error near unexpected token `(’

didn’t ask it to save anything tho… still made a new db file with some names gotten from the parameters i added in my attempts to get it to work.

just started throwing out the syntax error instead of the first error i got…
and didn’t fix it after i deleted the newly created blablablareputation.db file

so the reputation.db doesn’t come back after i deleted it, even after i removed the node from docker updated and relaunched it… hopefully it will be there tomorrow.
not like i need to keep track of my reputation anyways… i mean thats the satellites are for right…

the boot node logs seems fine, even the debug messages seems fine… i bet the damn .db file will be back tomorrow…

Oops!

I’m not sure what happens if one deletes the reputation database. Certainly the dashboard will no longer function correctly… hopefully the satellites maintain their own version so you are only missing the local version.

A good rule of thumb is: Don’t delete anything you’re not sure needs to be deleted.

A better rule is: Make a backup copy of files you’re not sure need to be deleted, before you delete them.

very true, but i did… mainly because i read somewhere that the fix for a bad config.yaml was to delete it and its in sort of the same folder… so… and it didn’t seem to contain anything more than a record…
everything works fine tho… haven’t rebooted the server tho… but did reboot and rerun the node from scratch… eveything is peachy… not sure if it will stay that way tho…

the reputation.db file hasn’t been restored yet tho…

i mean seriously how important can it be… i can restore the node from the data and the identity files… this should mainly just be config related and maybe log related… so im 98% sure its irrelevant and should auto correct given a while…

besides every seems fine… i should really start making use of my snapshot feature in zfs… its basically free to take backup and i have yet to use the feature 6 weeks in lol

the node has literally never been running better … got an avg of 4mb/s ingress over the last 30min…
been close to that , but not actually sustained it for any length of time before… or atleast i could see in my avg graphs over extended periods of time

You can recreate it yourself

sqlite3 reputation.db

CREATE TABLE reputation (
                                                satellite_id BLOB NOT NULL,
                                                uptime_success_count INTEGER NOT NULL,
                                                uptime_total_count INTEGER NOT NULL,
                                                uptime_reputation_alpha REAL NOT NULL,
                                                uptime_reputation_beta REAL NOT NULL,
                                                uptime_reputation_score REAL NOT NULL,
                                                audit_success_count INTEGER NOT NULL,
                                                audit_total_count INTEGER NOT NULL,
                                                audit_reputation_alpha REAL NOT NULL,
                                                audit_reputation_beta REAL NOT NULL,
                                                audit_reputation_score REAL NOT NULL,
                                                disqualified TIMESTAMP,
                                                updated_at TIMESTAMP NOT NULL,
                                                PRIMARY KEY (satellite_id)
                                        );

.quit
2 Likes

zfs snapshot is not “free”. If data on your node gets deleted, the snapshot would still contain that data so your used space doesn’t drop until that snapshot gets removed.

It is free in terms of performance and almost free if files are not modified or deleted often.

thx, you wise and bored almost all knowing bastard… xD
see i knew it wasn’t that important a file … lol

check your logs how often files get deleted. I wouldn’t want to keep them around. But if you only keep a snapshot for a few days, it shouldn’t be too much of a problem.

true… hench the basically… i know there are some limitations with it, but its not like i need to backup the blobs folder…
and you only loose the space required to store the changes from the snapshot… very green with zfs here… so really got no idea… which is why i haven’t used it yet lol

pretty sure the logs would compress quite nicely on zfs in their own folder with gzip-9 in compression

well I am just copying my old node to my new drive with zfs and recordsize=1M and my current compressratio is 1.33x with lz4! So this is actually a quite nice gain from compressing the blobs folder.
Before I had it on a drive with recordsize=128k (standard) and only got a compressratio of 1.06%.
I think I may migrate all my nodes to zfs :smiley:

wow that’s neat, have been testing compression, but didn’t really see any gains to make me want to use it… but ill certainly give that a try sometime in the near future. 1.33x would be brilliant…
did some tests with gzip-9 but it caused a good deal of iodelay on my cpu’s so just disabled it completely.
wasn’t seeing any compression with lz4 but not sure if my recordsize is standart… seemed odd to be honest… had 1.00x on my storage folder… but kinda messed it up, didn’t created it as a seperate data set from the rest… other stuff like vm’s disks did compress tho… so duno… was weird
thanks for a great tip

4 posts were merged into an existing topic: New Tardigrade satellite?

like @beast predicted my web dashboard died.
i tried stopping, removing the node and launching the run command, pretty sure nothing relevant has changed aside from me deleting the reputation.db and recreating it again using the command from your post.

was i suppose to add data in sqlite3 command or keep it as is?
because that is my best guess for why my webdash is down… tho haven’t tried to reboot the host OS… so maybe it will fix itself when i do that… i plan on getting that done tomorrow if i haven’t gotten the webdash fixed.

anyways, i was hoping you might in your great wisdom might have a suggestion.

i also have access to other webservices on the same ip, so no firewall stuff or such, and it used to work before i fucked the .db…
did disable ipv6… my swap on the host OS, but yeah nothing that should even remotely explain this.
was seeing some iowait peaks, turned out tinkering with a VM’s RAM, made the host OS swap and well lead to Iowaits which correlated with some ipv6 so i keeled it, but not like it ipv6 was configured anyways… so…

the webdash site just times out…like its service crashed and isn’t restarting… is there a way to check that…

No, but it might take a while until the satellites update your nodes information again. Just make sure it’s running and check back every once in a while. Also use CTRL+F5 to refresh.

You can check whether the sats have updated the reputation data like this.

sqlite3 reputation.db "select * from reputation"
1 Like

thx, ill see if it start working in the next couple of days then, no point in trying to fix something that most likely fixes itself.

That command doesn’t fix anything, it just shows you what’s in the table. If you get an empty response, that may be your issue. If you see 6 lines, one for each satellite, then that’s not your issue and something else is going on.

just checked, it’s still empty so you are most likely spot on…