RPi Storj Node setup step not working: Docker permission denied

I am a longtime node operator who just moved cross-country, and when I tried to set up my Windows rig again I made the fun discovery that it no longer powers on after making the trip.

I decided to make the switch to a Raspberry Pi Model 3 to set up a new node. I’m following the steps on this guide and most steps including creating and signing a node identity went by without issue. However, When I got to Docker setup, I ran into problems.

I’m on the step “Download Docker container with storagenode.” When SSH’d into my Pi through Putty, I tried to run this command:
docker pull storjlabs/storagenode:latest

Which returned this result:
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http://%2Fvar%2Frun%2Fdocker.sock/v1.24/images/create?fromImage=storjlabs%2Fstoragenode&tag=latest": dial unix /var/run/docker.sock: connect: permission denied

Any idea what’s going on that I can’t pull down Docker?

You either need to add user to the docker group or run with sudo…


That worked, thank you! I feel silly now…

By the way, when picking an internet interface for No-IP on the Pi, would I want to pick eth0 or docker0? (Docker’s virtual internet interface)

1 Like

Always use eth0 on a local network it cannot access docker0.


Did you want to migrate the Windows node to the Pi? Because if you created a new identity it will be the same as starting over.
If you are ok with starting over, make sure that you formatted HDD to ext4, because NTFS working slow and unreliable under Linux.

1 Like

@Alexey I might try and resurrect the Windows node too, because I think it’s just a power supply issue - But I had another 8-terabyte drive laying around so I figured it wouldn’t hurt to start another node.

I did just discover after setting up the new node (formatted to ext4 as well) that my apartment’s ISP blocks port forwarding, so I did open a new thread to try and figure out how to get around that with a Pi.