S3 gateway times out

Hi all,

I am trying out the Tardigrade network, and I am running into a problem with the S3 gateway. I setup the uplink. I and I am able to create buckets and manipulate files using the uplink cli. However, after succesful setup of the S3 gateway

user@ubunut-gateway-storj:~$ ./gateway_linux_amd64 run
2020-02-03T11:22:50.302Z        INFO    Configuration loaded from: /home/user/.local/share/storj/gateway/config.yaml
2020-02-03T11:22:50.302Z        INFO    running on version v0.31.12
2020-02-03T11:22:50.303Z        INFO    Starting Storj S3-compatible gateway!
2020-02-03T11:22:50.303Z        INFO    Endpoint:
2020-02-03T11:22:50.303Z        INFO    Access key: xxx
2020-02-03T11:22:50.303Z        INFO    Secret key: xxx

I am unable to use the aws S3 cli or rclone to create buckets/ manipulae files.
The error I get is:

user@ubunut-gateway-storj:~$ aws s3 --endpoint=http://localhost:7777/ ls

Read timeout on endpoint URL: "http://localhost:7777/"

Am I missing something very obvious? Is there some port forwarding issue?

Any help would be appreciated:)

Hey there!

Are you including the bucket name at the end?

aws s3 --endpoint=http://localhost:7777/ ls s3://bucket-name/

I get:

Could not connect to the endpoint URL: "http://localhost:7777/test?list-type=2&delimiter=%2F&prefix=&encoding-type=url"


Are you able to connect to any other services via localhost on your machine? Maybe try changing http://localhost:7777 to and see if that works?

Same result. May be I didn’t setup the S3 cli properly… But if that was the issue I should not get a working command prompt with the S3 commands…

Does it work if you request http://localhost:7777 in your web browser? Normally, it should display the Minio web interface.


Also I am running the gateway on Ubuntu 19.01 server, so I have access the web interface from another machine with 192.168.0.xxx:7777.

By default, you cannot access the gateway from another system because the default server address is bound to

Run the gateway with this command and try again:

./gateway_linux_amd64 run --server.address

Yep, I get minio gui now.

Cool! This means that the gateway is running properly.

Can you try again the AWS S3 CLI?

Works now!

So did running it with --server.address solved it?

When I am in command prompt and run ./gateway run is it correct to exit the prompt with ctrl+z, if I want the gateway to keep running of course? Or is there a better way to do so?

Rclone from another machine on the network works too now! Very excited :star_struck: :star_struck:

I am not sure why you couldn’t connect to the gateway from the same system when running on the default server address. Might be due to some specific configuration on that system.

But, anyway, if you need to connect to the gateway from another system, you need to change the server address as described.

If you want to disconnect your terminal from the Ubuntu server, I would recommend to setup the gateway as a service. There are many guides on Internet how to do this. Here is an example: https://stackoverflow.com/questions/38739198/how-to-run-a-script-as-a-service-in-ubuntu

Will try, thank you :grinning: