Server just went down - cant boot storagenode back up

Hi - my server just shut down and wont boot up - what do i do?

This is the error i get when i use the ‚Äúrun‚ÄĚ command
I have looked in the config.yaml file and email and wallet is filled out.
And it was working like 4 hours ago

I looked in the wrong config file - i fixed it.

Just dont understand how my config got mixed up tho.

Okay never mind
I just did a reboot and it is still offline - im gonna need some help. I looked in windows services and it gave my this error (in danish) when i tried to press start.

When i run my storage node manually it seems to boot fine.

But after a restart it does no longer auto boot… What to do? im on windows.

Still manual boot works just fine. i can find the service in windows services but cant start it from there. I can start i from CMD. If i restart the PC storj does not boot back up.

If you run the storagenode binary from the command line, you should provide options to specify correct location for config file with --config-dir option, identity location with --identity-dir option.
Without options it will create a config file, your storage location in %AppData% on your system disk by default. Unlikely you wants this.
If your node were running as a service, it used the config file from "C:\Program Files\Storj\Storage Node\config.yaml", and your storage location likely were on a different disk, not in %AppData%. So now your node under a risk of failing audits and on the way to disqualification, because a previous data is on other location.

When you figure out, where your previous location is (it is a storage.path option in the config file), you likely will need to merge blobs folder from the %AppData%\Storj\Storagenode with blobs folder in the correct location without overwrite of existing files, so add only new ones. This will allow your node to survive, when you fix the underlying issue.

Please try to start the service and post 20 last lines from your logs: How do I check my logs? | Storj Docs

So what you mean is: when i open CMD and type ‚Äústoragenode run‚ÄĚ i need additional parameters? i thought they where just in my config file?

I do belive that my storage is being saved to the correct spot atm.
I see blobs have been edited or added to the correct drive - so i think ‚Äúboth‚ÄĚ config files saves it to the right place?

i honestly have no clue what to do to fix my issue.

Im just gonna post my logs:

I tried to retrive logs but i dont think the file called ‚Äústoragenode.log‚ÄĚ actually exists anywhere?

Oh never mind - the logs is just a txt file: i think i got it?

Yes, you must do so, unless you did setup your node without an installation wizard and used default location for config file (%AppData%\Storj\Storagenode) and default location for identity (%AppData%\Storj\Identity\storagenode).

If you used a wizard, then started a node from the command line without options - it will use the default ones and creates config file, storage location in %AppData% as you showed here

And this location is definitely did not match this one

So, if you continue run your storagenode from the command line, it will store data in a different location and eventually will be disqualified for losing a previous data.

From your next screenshots I can assume that you provided a different path to the wizard for storagenode installation location, so your command to see logs will be

Get-Content -Tail 20 C:\Storj\storagenode.log

And the correct config file is C:\Storj\config.yaml

1 Like

From your screenshot of the text (please do not do that next time, post the text instead of picture) I can see, that something stopped the service.
Is the storagenode-updater service running? If so, check its logs:

Get-Content -Tail 20 C:\Storj\storagenode-updater.log

From your messed setup I can guess, that you now have at least three wrong storage locations:

  1. in %AppData%, the folder storage
  2. In C:\Storj, the folder storage
  3. In some disk with folder StorjData (this one seems the initial location)
1 Like

Okay - this is a little hard for me but i am trying my best.

just ran this command as i belive you meant.?

The node did not boot with the above command - and the config file in the destination is double checked to be OK.

Yes, I mean that.

Please add another option --log.output stderr, we will see, what’s wrong with this config file.

Got it

I see. This is encoding with BOM, so you have used a regular Notepad to edit your config and it broken your config file.

Open this config file with a Notepad++ and save with encoding UTF8 without BOM.

I will open in notepad++ and try

it seems to allready be?

image

Ok, this is better.
Now please delete the file C:\Storj\trust-cache.json and try to start the service, then check your logs